Bug 488855 - livecd-iso-to-disk fails with VFAT target disk, mmove segfault
livecd-iso-to-disk fails with VFAT target disk, mmove segfault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mtools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-05 18:03 EST by Warren Togami
Modified: 2013-04-30 19:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 16:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-03-05 18:03:08 EST
livecd-tools-021 + latest git
mtools-4.0.0-4.fc11
syslinux-3.73-2.fc11

livecd-creator succeeds with latest code from git that deals with the new paths of syslinux stuff.  However, livecd-iso-to-disk fails to install onto a VFAT formatted disk.  syslinux execution calls mmove, which segfaults.

s:/LiveOS/syslinux/ldlinux.sys: no match for target
   (mmove segfault happens here)
syslinux: warning: unable to move ldlinux.sys 

Core was generated by `mmove -D o -D O s:/ldlinux.sys s:/LiveOS/syslinux/ldlinux.sys'.
Program terminated with signal 11, Segmentation fault.
#0  0x080610ef in _mwrite_one (Dir=0x0, argname=0x9b99f40 "ldlinux.sys", shortname=0x0, cb=0x8062a1c <renameit>,
    arg=0xbffcb060, ch=0xbffcb53c) at mk_direntry.c:522
522        doscp_t *cp = GET_DOSCONVERT(Dir);
(gdb) bt
#0  0x080610ef in _mwrite_one (Dir=0x0, argname=0x9b99f40 "ldlinux.sys", shortname=0x0, cb=0x8062a1c <renameit>,
    arg=0xbffcb060, ch=0xbffcb53c) at mk_direntry.c:522
#1  0x080614c9 in mwrite_one (Dir=0x0, _argname=0xbffcb138 "ldlinux.sys", _shortname=0x0, cb=0x8062a1c <renameit>,
    arg=0xbffcb060, ch=0xbffcb53c) at mk_direntry.c:639
#2  0x08062dac in rename_file (entry=0xbffcab6c, mp=0xbffcb068) at mmove.c:132
#3  0x08055be6 in handle_leaf (direntry=0xbffcab6c, mp=0xbffcb068, lookupState=0x0) at mainloop.c:224
#4  0x0805630d in recurs_dos_loop (mp=0xbffcb068, filename0=0xbffcb914 "ldlinux.sys", filename1=0x0, lookupState=0x0)
    at mainloop.c:389
#5  0x08056507 in common_dos_loop (mp=0xbffcb068, pathname=0xbffcb913 "/ldlinux.sys", lookupState=0x0, open_mode=2)
    at mainloop.c:437
#6  0x0805657e in dos_loop (mp=0xbffcb068, arg=0xbffcb911 "s:/ldlinux.sys") at mainloop.c:450
#7  0x08056890 in main_loop (mp=0xbffcb068, argv=0xbffcb7a8, argc=1) at mainloop.c:553
#8  0x08063414 in mmove (argc=7, argv=0xbffcb794, oldsyntax=0) at mmove.c:302
#9  0x08066d26 in main (argc=7, argv=0xbffcb794) at mtools.c:167
Comment 1 Jeremy Katz 2009-03-06 13:08:52 EST
It looks like this is fixed by rebuilding with the current upstream (4.0.9) of mtools although I'm not seeing the specific change that would lead to it.  And my build is a bit of a hack (dropping patches that don't apply anymore) and so isn't generally useful.
Comment 2 Adam Tkac 2009-03-09 16:40:16 EDT
fixed in mtools-4.0.9-1.fc11

Note You need to log in before you can comment on or make changes to this bug.