Bug 488868 - REVIEW: Review installation requirements for IPA 2.0
Summary: REVIEW: Review installation requirements for IPA 2.0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: freeIPA
Classification: Retired
Component: Documentation
Version: 2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: v2 release
Assignee: Rob Crittenden
QA Contact: Chandrasekar Kannan
URL: http://documentation-stage.bne.redhat...
Whiteboard:
Keywords: Documentation
Depends On:
Blocks: 431020 freeipa20 488873 489811
TreeView+ depends on / blocked
 
Reported: 2009-03-06 01:22 UTC by David O'Brien
Modified: 2015-01-04 23:36 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-02-14 16:00:38 UTC


Attachments (Terms of Use)

Description David O'Brien 2009-03-06 01:22:53 UTC
Description of problem:

Need to review Section 2. "Preparing for an IPA Installation" to determine what changes are necessary for IPA 2.0

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David O'Brien 2009-03-08 21:55:18 UTC
Version set to 1.1 by  mistake. Resetting to 2.0

Comment 2 Rob Crittenden 2010-05-14 18:45:01 UTC
2.1 There is not a dogtag/RHCS already configured

2.2

These ports need to be unused on the system but do not (and probably should not) be opened on the system firewall):

9443, 9444, 9445, 9446: CA

2.3 If a client is installed with the --mkhomedir option then pam_mkhomedirs will be enabled so home directories can be created on-the-fly. This is a per-client installation option, there is no global option for it.

2.4 NSCD is disabled when sssd is used (the default).

2.5.1 We will want to re-test this with EL 6 but I don't think we need to disable NM any more. I don't with F11 and 12.

2.7 We will only support F12+. F12 currently ships with kerberos 1.7.1

3.1 We no longer require TurboGears but we added dogtag/RHCS will pulls in tomcat and java, so 140+ packages in all.

3.2 Replace TurboGears with dogtag. The uid/gid ranges documentation may change when we implemented Managed Private Groups.

The rest looks ok.

Comment 3 Deon Ballard 2011-05-18 23:56:11 UTC
Removing bugs from the 6.1 tracker that should block the 6.2 tracker.

Comment 4 Rob Crittenden 2014-02-14 16:00:38 UTC
This relates to docs of a couple of versions ago. The current docs are correct related to installation requirements, closing this.


Note You need to log in before you can comment on or make changes to this bug.