Bug 488900 - Document standard IPA input format
Document standard IPA input format
Status: CLOSED DUPLICATE of bug 488891
Product: freeIPA
Classification: Community
Component: Documentation (Show other bugs)
2.0
All Linux
low Severity low
: future release
: ---
Assigned To: David O'Brien
Chandrasekar Kannan
: Documentation
Depends On:
Blocks: 431020 freeipa20 489811 646217
  Show dependency treegraph
 
Reported: 2009-03-06 00:08 EST by David O'Brien
Modified: 2015-01-04 18:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 21:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2009-03-06 00:08:14 EST
Description of problem:


Version-Release number of selected component (if applicable):


Additional info:
if a customer wishes to migrate data from a directory that uses non-standard schema or layout they will need to export their data and map it into this input format.

I don't expect this to be extensive, but I don't know
Comment 2 David O'Brien 2010-01-31 23:01:06 EST
afaik this is handled by scripts and is part of the migration effort, is that right?
Comment 4 Pavel Zuna 2010-02-01 10:23:29 EST
As long as users have the 'person' objectClass and groups have the 'groupOfUniqueNames' objectClass, everything should go fine with no additional work. Users only need to import their custom objectClasses and attributes to the IPA schema if they want to continue using them. Honestly, we only tested migration on DS with the default schema. If someone would provide me with a custom schema, I'll do more tests. In any case, search filters and handlers for objects being migrated can be customized easily, although it required some programming skills.
Comment 7 David O'Brien 2010-09-14 21:54:23 EDT

*** This bug has been marked as a duplicate of bug 488891 ***

Note You need to log in before you can comment on or make changes to this bug.