Bug 488947 - hal doesn't mount MP3 player/USB stick/External USB disk
hal doesn't mount MP3 player/USB stick/External USB disk
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 07:28 EST by antonio montagnani
Modified: 2009-08-17 23:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 517941 (view as bug list)
Environment:
Last Closed: 2009-04-17 17:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2009-03-06 07:28:59 EST
Description of problem:
no external mass storage devices cannot be mounted

Version-Release number of selected component (if applicable):
hal.i586 0.5.12-24.20090226git.fc11

How reproducible:
always

Steps to Reproduce:
1.connect any USB mass storage device
2.
3.
  
Actual results:
No device is mounted but it is seen in the computer window but it cannot be mounted

Expected results:
it should work and devices mounted

Additional info:
it is a cyclic bug.Systems are fully updated up to today.
In F10 there is a similar problem, MP3 player is not mounted but an USB stick is mounted.
Comment 1 antonio montagnani 2009-03-06 07:51:46 EST
and also DVD and CD are not mounted!!!! DVD player is not shown in the computer window while CD player is shown but cannot be used!!!
Comment 2 antonio montagnani 2009-03-07 07:54:00 EST
after this morning updates (at 12 UTC) now I all is o.k. with the exception on an USB media player that is present in Computer window but it not automounted (and it was..).In Computer Window is seen as ACTIONS HS USB Flashdisk,
lsusb
Bus 001 Device 017: ID 10d6:1101 Actions Semiconductor Co., Ltd D-Wave 2GB MP4 Player / AK1025 MP3/MP4 Player

Other USB sticks are automounted...
Comment 3 Steven Usdansky 2009-03-07 10:51:45 EST
After this morning's update and a reboot, I still get:

Unable to mount Transport4a
org.freedesktop.PolicyKit.Error.NotAuthorized: org.freedesktop.devicekit.disks.filesystem-mount no

when trying to mount a USB stick

However, GnomeMenu->System->Preferences->Authorizations shows (copied by hand):

Action
  Identifier: org.freedesktop.devicekit.disks.filesystem-mount

Implicit Authorizations
  Anyone:         Yes
  Console:        No
  Active Console: Yes
Comment 4 antonio montagnani 2009-03-09 01:31:56 EDT
additional info:

Same MP3 player is not auto-mounted when connected also in F10 (and cannot be mounted also in the graphic environment) but it is shown in Resources as USB unit (and also in Computer Windows).
Full updated F10 system
Comment 5 antonio montagnani 2009-03-11 11:38:23 EDT
after today's update in F10 and Rawhide, my Mp3 player is auto-mounted in both system.

in Rawhide, it is mounted as 44F6-7DCD in /media....why??
Comment 6 Richard Hughes 2009-03-12 05:44:50 EDT
(In reply to comment #5)
> in Rawhide, it is mounted as 44F6-7DCD in /media....why??  

It's using DeviceKit-disks, and this looks like your UID.
Comment 7 James Walsh 2009-03-23 22:51:26 EDT
I am also unable to mount any kind of usb mass storage. running latest rawhide as of 24/3.

kernel finds the device fine, however does not mknod the devices partitions, e.g. there will be /dev/sdc but no /dev/sdc1 /dev/sdc2 etc.

fdisk -L output on an 8gig phone on mass storage is as follows.

Disk /dev/sdc: 8119 MB, 8119123968 bytes
1 heads, 62 sectors/track, 255768 cylinders
Units = cylinders of 62 * 512 = 31744 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1             133      253688     7860224    b  W95 FAT32
Partition 1 does not end on cylinder boundary.

so while fdisk says /dev/sdc1 exists, there is no special file in /dev with the same name. thusly I cannot even manually mount it.

Any help is appreciated.
Comment 8 Steven Usdansky 2009-03-30 18:02:21 EDT
F11-alpha with kernel-PAE upgraded to 2.6.29-16 on Acer Aspire One. Gnome disk-mount applet shows inserted SD cards and USB sticks. Devices appear in /dev. Disk-mount applet cannot mount these devices. Nautilus cannot mount these devices. Devices are mountable from a gnome-terminal (by the ordinary user) with command: gnome-mount -d /dev/<dev-name> at which point the device appears on the desktop. User can umnount the device by right-clicking on its desktop icon.
Comment 9 Todd Bailey 2009-08-17 23:34:01 EDT
org.freedesktop.PolicyKit.Error.NotAuthorized: org.freedesktop.devicekit.disks.filesystem-mount no


after upgrading to newest kernal F11 - 2.6.29.6-217.2.7.fc11.i686.pae

problem still exists.

need work around/procedures to make device usable.

Note You need to log in before you can comment on or make changes to this bug.