Bug 488970 - script-fu: gimp_wire_read(): error -> segfault
script-fu: gimp_wire_read(): error -> segfault
Status: CLOSED DUPLICATE of bug 486122
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 10:46 EST by Matthew Miller
Modified: 2009-03-06 11:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 11:25:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2009-03-06 10:46:28 EST
Description of problem:

Gimp crashes with 

(script-fu:6194): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Segmentation fault


Version-Release number of selected component (if applicable):

Pretty sure it started with gimp-2.6.5-1.fc11.x86_64; still happens with 
gimp-2.6.5-2.fc11.x86_64.

How reproducible:

Inconsistent, but frequent.

Steps to Reproduce:
1. Open gimp, do stuff.
2. Sometime in the session, when you click on the menu, boom. (Not necessarily the script-fu menu.)
  
Actual results:


(script-fu:6194): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Segmentation fault

The number varies; I  assume it's a PID.

Expected results:

No crash.
Comment 1 Matthew Miller 2009-03-06 11:03:06 EST
I should add that I've tried moving my .gimp-2.6/ out of the way so it's starting with a clean profile — no improvement.
Comment 2 Matthew Miller 2009-03-06 11:09:58 EST
In this example, I ran gimp and then simply clicked on the file menu — no other actions. Before the menu even popped up, crash:

$ gimp --stack-trace-mode=always
gimp: fatal error: Segmentation fault
#0  0x00000036efa0ea5d in waitpid () from /lib64/libpthread.so.0
#1  0x00000036f0614ff2 in g_on_error_stack_trace ()
#2  0x0000000000467be3 in ?? ()
#3  0x0000000000467d2d in gimp_fatal_error ()
#4  0x00000000004686df in ?? ()
#5  <signal handler called>
#6  0x00000036f0e10317 in g_object_get () from /lib64/libgobject-2.0.so.0
#7  0x00000000005936ba in ?? ()
#8  0x00000036f0e0b8ee in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#9  0x00000036f0e21ef8 in ?? () from /lib64/libgobject-2.0.so.0
#10 0x00000036f0e232de in g_signal_emit_valist ()
#11 0x00000036f0e23873 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#12 0x00000036f87586e8 in gtk_menu_item_select ()
#13 0x00000036f875cec2 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#14 0x00000036f875ddbb in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#15 0x00000036f874b713 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#16 0x00000036f0e0b8ee in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#17 0x00000036f0e21bb0 in ?? () from /lib64/libgobject-2.0.so.0
#18 0x00000036f0e2319e in g_signal_emit_valist ()
#19 0x00000036f0e23873 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#20 0x00000036f886b9bf in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#21 0x00000036f8742875 in gtk_propagate_event ()
#22 0x00000036f87439cb in gtk_main_do_event ()
#23 0x00000036f825322c in ?? () from /usr/lib64/libgdk-x11-2.0.so.0
#24 0x00000036f063812e in g_main_context_dispatch ()
#25 0x00000036f063b888 in ?? () from /lib64/libglib-2.0.so.0
#26 0x00000036f063bd25 in g_main_loop_run () from /lib64/libglib-2.0.so.0
#27 0x0000000000467524 in app_run ()
#28 0x0000000000468538 in main ()

(script-fu:6670): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Comment 3 Matthew Miller 2009-03-06 11:25:16 EST

*** This bug has been marked as a duplicate of bug 486122 ***

Note You need to log in before you can comment on or make changes to this bug.