Bug 488989 - Mid-layer underflow detected message from qla2xxx
Mid-layer underflow detected message from qla2xxx
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
ppc64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 11:42 EST by Jan Tluka
Modified: 2012-06-14 16:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:06:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHTS messages log (1.33 MB, text/plain)
2009-03-06 11:52 EST, Jan Tluka
no flags Details

  None (edit)
Description Jan Tluka 2009-03-06 11:42:35 EST
Description of problem:
When testing internal beta of RHEL4.8 I hit one message from qla2xxx driver.
--
qla2300 0000:01:01.0: scsi(0:0:0:1): Mid-layer underflow detected (c000 of c000 bytes)...returning error status.
--
This gets repeated many times.
(full log available here: http://rhts.redhat.com/testlogs/48839/164792/1378770/messages)

I see this on RHTS system ibm-js20-02.lab.bos.redhat.com when running
stress test on the kernel (/kernel/distribution/stress-kernel).
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=48839

Version-Release number of selected component (if applicable):
RHEL4-U8-re20090227.1
kernel 2.6.9-82.EL

How reproducible:
Not sure, but message appears when running stress test on specific system in RHTS.

Steps to Reproduce:
1. Run /kernel/distribution/stress-kernel test on RHTS system ibm-js20-02.lab.bos.redhat.com.
2. Check messages log for the qla2xxx message

Actual results:
Following message appears on console:
qla2300 0000:01:01.0: scsi(0:0:0:1): Mid-layer underflow detected (c000 of c000 bytes)...returning error status.

Expected results:
No underflow detected.

Additional info:
I've been searching in bugzilla and found bug for RHEL5.4 that seems to be related (same message appears there): bug 470510
However I did not hit panic.

This message was present in 4.7, too, so this is not a regression.
See RHTS job http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=40612
Comment 1 Jan Tluka 2009-03-06 11:52:54 EST
Created attachment 334321 [details]
RHTS messages log

The log from RHTS job, look for string qla2300.
Comment 2 RHEL Product and Program Management 2009-03-12 14:56:16 EDT
Since RHEL 4.8 External Beta has begun, and this bugzilla remains 
unresolved, it has been rejected as it is not proposed as exception or 
blocker.

Note You need to log in before you can comment on or make changes to this bug.