Bug 48899 - Disk Druid and Installer AutoPartition recognize only hard drive from 1 controller in multiple SCSI adapters system
Disk Druid and Installer AutoPartition recognize only hard drive from 1 contr...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-12 09:31 EDT by Bryan Leopard
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 09:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-07-12 09:31:30 EDT
Hardware Settings:
DL320 SCSI (04/11/01) > 18.2GB SCSI HDD
Compaq 64 bit/66 Mhz Wide Ultra 3 SCSI (2.52.1) > StorageWork > 9.1 GB 
SCSI HDD

Software:  Redhat Fairfax Beta 1

Steps to duplicate:
1.  Choose custom system install
2.  Manually partition with Disk Druid
3.  Get message :  Unable to open /tmp/sda - unrecognize disk label.  > 
Click Next -  see only harddrive from 1 controller.

4.  Installer Autopartition option ALSO seems to recognize only hard drive 
from 1 controller.

Workaround:  Choose Manually Partition with fdisk - recognize drives from 
both controllers.

More NOTES:
After partitioning a disk with fdisk, Disk druid does not recognize 
partition type on second partition - It pops up "You cannot edit 
partitions without a filesystem type" error message. 
If there are /boot(/tmp/sda1) and /root(/tmp/sda2) partitions made, 
installation fails because installer does not recognize /root partition 
type.
Comment 1 Matt Wilson 2001-07-12 10:36:08 EDT
beta1 only displayed drives with valid partition tables.  Did you have a sda
(which disk druid couldn't understand the partition table) and a sdb that showed
up?  If so, this is fixed in beta2, as you will have the chance to make a fresh
partition table on disks that have no valid table.

The second problem is probably that the filesystem was dirty on your /boot
partition.  Disk Druid would refuse to see these as ext2.  This is also fixed in
beta2.

Note You need to log in before you can comment on or make changes to this bug.