Bug 489018 - Blender crashes playing yofrankie game
Blender crashes playing yofrankie game
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: blender (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 13:59 EST by Alexey Torkhov
Modified: 2009-03-11 12:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 12:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Torkhov 2009-03-06 13:59:06 EST
Description of problem:
When running yofrankie game from review (bug 486758), in crashes after selecting "Play" in menu.

Console output:
guessing 'blenderplayer' == '/usr/bin/blenderplayer'
argv[0] = 'blenderplayer'
argv[1] = '/usr/share/yofrankie-bge/levels/start_menu.blend'   , 2
read library: lib //../chars/butterfly.blend
Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Detected GL_ARB_multitexture
Detected GL_ARB_shader_objects
Detected GL_ARB_vertex_shader
Detected GL_ARB_fragment_shader
Detected GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color
No CDROM devices available
No CDROM devices available
/usr/bin/yofrankie-bge: line 2:  9056 Segmentation fault      (core dumped) blenderplayer /usr/share/yofrankie-bge/levels/start_menu.blend

Backtrace:
#0  0x00000000005224d4 in get_viewedit_datamask ()
#1  0x000000000051a367 in object_handle_update ()
#2  0x0000000000511079 in group_handle_recalc_and_update ()
#3  0x000000000051e19a in object_duplilist_recursive ()
#4  0x000000000051e3b2 in object_duplilist ()
#5  0x00000000005e280f in GPU_shaderesult_set ()
#6  0x00000000005e354d in GPU_blender_material ()
#7  0x00000000005e360c in GPU_material_from_blender ()
#8  0x000000000066ee05 in KX_BlenderMaterial::SetBlenderGLSLShader ()
#9  0x0000000000671366 in KX_BlenderMaterial::OnConstruction ()
#10 0x0000000000649392 in BL_ConvertMesh ()
#11 0x0000000000649eb8 in gameobject_from_blenderobject ()
#12 0x000000000064a55b in BL_ConvertBlenderObjects ()
#13 0x00000000006415cd in KX_BlenderSceneConverter::ConvertScene ()
#14 0x00000000004f0aec in GPG_Application::startEngine ()
#15 0x00000000004eee04 in main ()

I have NVidia GTX 260 card, driver version is 180.29 (from RPMFusion).

Version-Release number of selected component (if applicable):
blender-2.48a-4.fc10.x86_64
yofrankie-bge-1.4-0.1.20081221svn.noarch

How reproducible:
Always

Additional info:
Comment 1 Jochen Schmitt 2009-03-08 15:45:26 EDT
Because I have no ide why this is happen, I have created an upstream bug at:

https://projects.blender.org/tracker/index.php?func=detail&aid=18068&group_id=151&atid=445
Comment 2 Jochen Schmitt 2009-03-08 16:18:56 EDT
Unfortunately, I have post the wrong URL. It should be

https://projects.blender.org/tracker/index.php?func=detail&aid=18377&group_id=151&atid=445
Comment 3 Alexey Torkhov 2009-03-10 17:07:24 EDT
Seems crash is happening only with compressed blender files. If run it directly with svn sources, it works fine.
Comment 4 Lubomir Rintel 2009-03-11 07:56:22 EDT
(In reply to comment #3)
> Seems crash is happening only with compressed blender files. If run it directly
> with svn sources, it works fine.  

I've added some comments to the upstream bug Jochen filed and updated the yofrankie-bge package so that it does not crash now.

I believe this can be closed now, since it's reported upstream and doesn't bother us anymore. Thank you both for your efforts.
Comment 5 Jochen Schmitt 2009-03-11 12:01:28 EDT
OK, I will close this bug and wait for upstream.
Comment 6 Jochen Schmitt 2009-03-11 12:07:06 EDT
I have got a look to the upstream ticket system. Someone wrote, that a file in the yofrankie package may be corrupted. It may be nice, if you can update your package to the most current release and retry your test.
Comment 7 Lubomir Rintel 2009-03-11 12:20:31 EDT
(In reply to comment #6)
> I have got a look to the upstream ticket system. Someone wrote, that a file in
> the yofrankie package may be corrupted.

It was, in fact, me. I should probably have written "the file becomes corrupted" instead of "...is corrupted" -- it is not corrupted in distro, but becomes corrupted during save by the python script.

> It may be nice, if you can update your
> package to the most current release and retry your test.  

In meanwhile, I decided that we'll not compress the png graphics into jpeg, because the space gain doesn't outweight the quality loss, so we don't have to touch the .blend files at all. (and upstream doesn't compress the graphic files on DVD distribution anyways).

Note You need to log in before you can comment on or make changes to this bug.