Bug 489034 - backup jobs fail when rpm command is found several times in the PATH
backup jobs fail when rpm command is found several times in the PATH
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fwbackups (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Stewart Adam
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 15:59 EST by Misho Krastev
Modified: 2009-04-09 12:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.43.3-0.1.rc1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 12:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misho Krastev 2009-03-06 15:59:37 EST
Description of problem:

If the rpm command is found in multiple locations the PATH env variable fwbackups will create 'RPM - Package list.txt' files in the archive (one for each location). Consequently on the cleanup phase of the backup job the execution will fail because it will try to delete the same files more than one time.

Version-Release number of selected component (if applicable):

1.43.2-2.fc9

How reproducible:

Every time is rpm is found in more than one location.

Steps to Reproduce:
1. Add /bin twice to your PATH. 
2. Run backup job
3.
  
Actual results:

Backup fails due to exception when trying to remove 'RPM - Package list.txt' file.

Expected results:

Backup job should complete successfully.

Additional info:

Function createPkgLists (backend.py:352) needs a break statement after the first successful execution of the rpm command. This will prevent failures in cases where rpm command is found in more than one location in the PATH.
Comment 1 Stewart Adam 2009-03-07 01:36:30 EST
Thanks for the report - fixed locally, I will generate a patch and update the Fedora RPM soon until 1.43.3 is ready for release.
Comment 2 Fedora Update System 2009-03-23 00:10:14 EDT
fwbackups-1.43.3-0.1.rc1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/fwbackups-1.43.3-0.1.rc1.fc9
Comment 3 Fedora Update System 2009-03-23 11:54:56 EDT
fwbackups-1.43.3-0.1.rc1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update fwbackups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2936
Comment 4 Fedora Update System 2009-03-23 12:00:07 EDT
fwbackups-1.43.3-0.1.rc1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fwbackups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2972
Comment 5 Fedora Update System 2009-04-09 12:08:06 EDT
fwbackups-1.43.3-0.1.rc1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-04-09 12:10:16 EDT
fwbackups-1.43.3-0.1.rc1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.