Bug 489051 - running bkchem causes python errors and then aborts
running bkchem causes python errors and then aborts
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bkchem (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Henrique "LonelySpooky" Junior
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 17:57 EST by Aram Agajanian
Modified: 2009-03-09 19:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.13.0-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 19:00:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Workaround patch for this issue (1013 bytes, patch)
2009-03-08 11:17 EDT, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Aram Agajanian 2009-03-06 17:57:09 EST
Description of problem:
When bkchem is run from the command line, the following error is output and the window doesn't appear.

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/bkchem/bkchem.py", line 106, in <module>
    from main import BKchem
  File "/usr/lib/python2.5/site-packages/bkchem/main.py", line 24, in <module>
    from paper import chem_paper
  File "/usr/lib/python2.5/site-packages/bkchem/paper.py", line 30, in <module>
    from oasa.oasa.transform import transform 
ImportError: No module named oasa.transform


Version-Release number of selected component (if applicable):
bkchem-0.13.0-1.fc9.noarch

How reproducible:
happens every time

Steps to Reproduce:
1.run bkchem from command line
2.observe output
  
Actual results:
The python error shown above is generated.

Expected results:
A program window show appear.
Comment 1 Henrique "LonelySpooky" Junior 2009-03-06 18:53:21 EST
Hi, I'm working on this right now.
It seems to be an bug in the upstream code. I'm in touch with then to solve this.
Thanks for your report
Comment 2 Alexander 2009-03-08 08:56:22 EDT
Ah, I just found out the exact same problem.

With: bkchem-0.13.0-1.fc10.noarch
On: 2.6.27.15-170.2.24.fc10.i686

I hope it gets fixed soon, I really want to use bkchem asap.
Comment 3 Henrique "LonelySpooky" Junior 2009-03-08 10:41:07 EDT
I'll just do one step back untll we solve this problem
Comment 4 Mamoru TASAKA 2009-03-08 11:17:42 EDT
Created attachment 334437 [details]
Workaround patch for this issue

Possible workaround
Comment 5 Mamoru TASAKA 2009-03-08 11:20:27 EDT
(In reply to comment #3)
> I'll just do one step back untll we solve this problem  

Please don't do this...
Comment 6 Henrique "LonelySpooky" Junior 2009-03-08 12:41:45 EDT
Ok, I'll try the patch. Probably this Monday Beda (the upstream maintainer), will give us an answer and, maybe, an official fix.
Comment 7 Fedora Update System 2009-03-08 13:46:28 EDT
bkchem-0.13.0-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/bkchem-0.13.0-3.fc9
Comment 8 Fedora Update System 2009-03-08 13:48:22 EDT
bkchem-0.13.0-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bkchem-0.13.0-3.fc10
Comment 9 Henrique "LonelySpooky" Junior 2009-03-08 13:55:41 EDT
Mamoru's patch is working (thanks, Mamoru) and a new release of bkchem will be
hitting YUM repos soon.
When the package is pushed to stable this bug report will be closed.
Comment 10 Henrique "LonelySpooky" Junior 2009-03-09 07:55:51 EDT
Upstream give us an reply:
"Hi Henrique,

the suggested patch is a very elegant solution of the bug. I have
patched my source code and it will be part of the next release.
Thank you very much for your help.

    Best regards"
Comment 11 Fedora Update System 2009-03-09 19:00:28 EDT
bkchem-0.13.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-03-09 19:03:21 EDT
bkchem-0.13.0-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.