This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 489059 - scanning requires libhpmud.so which is removed in rpm install stage
scanning requires libhpmud.so which is removed in rpm install stage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 18:42 EST by Leo Bergolth
Modified: 2009-03-09 14:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.9.2-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 14:47:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo Bergolth 2009-03-06 18:42:27 EST
Scanning with hp-scan, scanimage or xscan fails because libhpmud.so is needed, which is removed during the RPM install stage:

strace of e.g.
  scanimage 'hpaio:/net/HP_LaserJet_M1522nf_MFP?ip=10.0.0.21'
shows:
open("/usr/lib/libhpmud.so", O_RDONLY)  = -1 ENOENT (No such file or directory)

Building a new RPM that just doesn't remove libhpmud.so fixes the problem.

See http://lists.debian.org/debian-printing/2009/02/msg00067.html for an equivalent bug report for debian.

Note You need to log in before you can comment on or make changes to this bug.