Bug 489068 - OCZ Vertex SSD serial number too long for dmraid
OCZ Vertex SSD serial number too long for dmraid
Status: CLOSED DUPLICATE of bug 490121
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 21:42 EST by Remy Maucherat
Modified: 2009-04-22 09:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 09:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Additional patch to be added to the RPM (649 bytes, patch)
2009-03-06 21:42 EST, Remy Maucherat
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 267953 None None None Never

  None (edit)
Description Remy Maucherat 2009-03-06 21:42:30 EST
Created attachment 334378 [details]
Additional patch to be added to the RPM

Description of problem:
The serial number of these SSDs are too long for dmraid.

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc15-6.fc11

How reproducible:
Always

Steps to Reproduce:
1. Use dmraid with OCZ Vertex SSD
2.
3.
  
Actual results:
Failure.

Expected results:
Correct handling of the serial number, even if it's long.

Additional info:
http://www.ocztechnologyforum.com/forum/showthread.php?t=52379
Verified the Fedora source, and it looks like it would be affected as well.
The attached patch ports the patch that Ubuntu has used to the dmraid-1.0.0.rc15 used in Fedora. Verified the RPM builds fine with it, but not actually tested (would need two of the SSDs).
Comment 1 Remy Maucherat 2009-03-11 20:34:08 EDT
Ping ? The report includes a ready-to-apply patch, which seems to fix a real issue (people who buy SSD often RAID 0 two or more small drives, since the chance of failure is very small and it hides their small sizes).
Comment 2 Hans de Goede 2009-04-22 09:59:06 EDT
Closing this as a dup of bug 490121, where some patches where thrown back and forward fixing this properly (note it is fixed in rawhide now).

*** This bug has been marked as a duplicate of bug 490121 ***

Note You need to log in before you can comment on or make changes to this bug.