Bug 48907 - Race Condition in msgBox can cause installer to emit Tcl errors
Race Condition in msgBox can cause installer to emit Tcl errors
Status: CLOSED DEFERRED
Product: Red Hat Database
Classification: Red Hat
Component: installer (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Neil Padgett
Neil Padgett
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-12 10:32 EDT by Neil Padgett
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 10:37:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Padgett 2001-07-12 10:32:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
Received an automated bug report (given in Additional Information) from an
internal user. It is indicative of a problem with the msgBox routine. It
seems that if a window is acted upon (moved / click on) just prior to
destruction, then by the time the action is executed the window is not
viewable, and a Tcl error results.


How reproducible:
Sometimes

Steps to Reproduce:
1. Install the database, or create some condition (previously installed
packages, unsatisfied dependencies, etc.) that will cause a msgBox the next
time the installer is run.
2. Re-run the installer.
3. When the msgBox is presented, acted on it normally. Then grab the msgBox
and proceed to "jiggle" it continually. This should cause the error to
present.
	

Actual Results:  The Tcl error above results. (Or a similar one.)

Expected Results:  Installer should continue normally. The actions should
be ignored.

Additional info:


--------------------------------------------------
   USER: Steven Taylor
  PHONE: x359
 E-MAIL: staylor@redhat.com
--------------------------------------------------

COMMENTS:
installer was going and i clicked another window and this popped up

ERROR:
grab failed: window not viewable

STACK:
grab failed: window not viewable
    while executing
"grab $win"
    (procedure "msgBox" line 136)
    invoked from within
"msgBox -title "Red Hat Database: Notice"  -message "The following packages
cannot be selected due to\nmissing dependencies or
conflicts:"  -list $dont..."
    (procedure "check_install_ok" line 64)
    invoked from within
"check_install_ok"
    (procedure "preinst" line 12)
    invoked from within
"preinst"
    invoked from within
"$packageParser eval $cmd"
    (procedure "run_pre_hooks" line 5)
    invoked from within
"run_pre_hooks"
    invoked from within
".logo.install invoke"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke]"
    (procedure "tkButtonUp" line 7)
    invoked from within
"tkButtonUp .logo.install
"
    (command bound to event)

Note You need to log in before you can comment on or make changes to this bug.