Bug 489075 - 1.2.13-7.fc10 entirely breaks keyboard input in UrbanTerror 4.1
1.2.13-7.fc10 entirely breaks keyboard input in UrbanTerror 4.1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 23:59 EST by tengel
Modified: 2009-06-26 10:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 10:03:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tengel 2009-03-06 23:59:49 EST
Description of problem:

The recent 1.2.13-7.fc10 upgrade of SDL on i386 32bit entirely breaks the keyboard input in the game UrbanTerror 4.1; no keystrokes are possible except CTL+AlT+BACKSPACE and C+A+D/power button interrupt.

Downgrading to 1.2.13-6.fc10 works as expected, keyboard input functions normally as it has for years. This only happens when you upgrade to the recently released -7 version of SDL.

Mouse still functions normally, or appears to as far as I could tell, with the -7 release; only the keyboard was affected.

Version-Release number of selected component (if applicable):

1.2.13-7.fc10

How reproducible:

100%

Steps to Reproduce:

1. Unpack the official distro of UrT 4.1. ioUrbanTerror.i386 is dynamically linked to libSDL-1.2.so.0.
2. Start game by running ./ioUrbanTerror.i386
3. No keyboard keystrokes are accepted by the game
  
Actual results:

No keystrokes are active in the game, to include spacebar, ~ key and others besides [A-Za-z0-9] normal keys.

Expected results:

Keyboard to function normally. :)

Additional info:

Dell XPSGenII laptop with external keyboard on USB hub - neither the laptop keyboard or the external keyboard works except the aforementioned C+A+B/C+A+D strokes. The kmod-nvidia drivers from RPMForge are installed in a basic manner, no special tweaking. nVidia GeForce Go 6800 Ultra is the specific graphics chipset. Rebooting into previous kernels with previous kmod-nvidia modules has no affect/does not help, it seems to be specifically the SDL package alone. This system has been playing UrT for a long time with multiple versions of Fedora.
Comment 1 Thomas Woerner 2009-06-03 09:54:32 EDT
The fixes in 1.2.13-7 should not affect keyboard input at all. Can you please try to verify which patch of Patch29 or Patch30 is causing your problem?
Comment 2 Hans de Goede 2009-06-26 10:03:20 EDT
You're using a precompiled binary, which is build against other versions of
libraries, etc. Then we have in Fedora, this is not supported.

Fedora actually contains its own ioquake3 binary which can be used to play urbanterror, and this works fine with the latest SDL (just tested).

You can install the Fedora compatbile quake3 binary with:
yum install quake3

Alternatively do:
yum install urbanterror

And then start urbanterror from the menu, this is a wrapper which
will download the urbanterror datafiles for you, put them in the right
place and start urbanterror.

Note You need to log in before you can comment on or make changes to this bug.