Bug 489079 - Open Office failed to start.
Open Office failed to start.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 02:45 EST by Digvijay Patankar
Modified: 2009-03-07 09:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-07 09:03:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Digvijay Patankar 2009-03-07 02:45:13 EST
Description of problem:Openoffice 3.0.1
Initially : Except 'Base' and 'Math' Apps.
When I try to open any other application, application do not start.
When I try to open 'Writer' it repeatedly gives 'Document Recovery' window.

After applying a bug fix (openoffice.org-ure-1:3.0.1-15.2.fc10 (i386)
application do not even give 'Document recovery' window.
All apps including 'Base' and 'Math' fail to open.

Resolved with : Removed Openoffice and reinstalled.
Then invoked the command : mv .openoffice.org backup-config
It was working fine.

And now : I again applied the bug fix "openoffice.org-ure-1:3.0.1-15.2.fc10 (i386)". But now no application(OOo) starts as before.
It gives an error :
$ openoffice.org3
/opt/openoffice.org3/program/soffice.bin: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory



Version-Release number of selected component (if applicable): 3.0.1
How reproducible: Install OOo 3.0.1.


Steps to Reproduce:
1.Install OOo 3.0.1.
2.apply bug fix "openoffice.org-ure-1:3.0.1-15.2.fc10 (i386)".
3.Try to run OOo any application.
  
Actual results: Do not start any application.


Expected results:Application should start.


Additional info: Same bug I filed to OOo. But someone commented to report it to fedora. Because its not the problem of bug fix according to him.
Comment 1 Caolan McNamara 2009-03-07 09:03:26 EST
/opt/openoffice.org3/program/soffice.bin is not the fedora OOo

What I bet you have done is you have installed the *vanilla* openoffice.org from www.openoffice.org and then upgraded the *vanilla* openoffice.org-ure subcomponent to the *fedora* openoffice.org-ure component and you're now in a muddle of mixed packages of all-vanilla components except a fedora openoffice.org-ure

here's one solution
yum -y erase openoffice.org-ure
that's remove openoffice.org-ure and everything that uses it, both fedora OOo and/or vanilla OOo

and then either 
install the fedora OOo again with system->administration->add/remove software. That's the supported route

Or install the vanilla OOo and *don't* upgrade the vanilla ure to the fedora ure, or tag it as not to be replaced (see man yum.conf and "exclude")

It's neither a bug of fedora or of upstream, they've ended up mixed.

Note You need to log in before you can comment on or make changes to this bug.