Bug 489101 - X locks up when dragging stuff i Firefox
X locks up when dragging stuff i Firefox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 11:11 EST by Pierre Ossman
Modified: 2009-04-21 07:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 07:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old (52.08 KB, text/plain)
2009-03-09 02:48 EDT, Pierre Ossman
no flags Details
messages (522.20 KB, text/plain)
2009-03-09 02:49 EDT, Pierre Ossman
no flags Details

  None (edit)
Description Pierre Ossman 2009-03-07 11:11:01 EST
Sometimes when I select a piece of text in firefox and begin dragging it, the X server locks up. It has time to change the cursor though, and cursor updates continue to work so it isn't completely hung. There are no other updates on the screen except for the cursor though.

This is extremely annoying as the only way to recover is a hard reboot. Just pressing the power button isn't working (probably as g-p-m is popping up its dialog on the unusable display).

My card is a NVS 140M (G8x) in a Thinkpad R61.
Comment 1 Ben Skeggs 2009-03-08 19:21:41 EDT
Can you upload your /var/log/Xorg.0.log.old and /var/log/messages from after you've done a hard reboot after the hang.
Comment 2 Pierre Ossman 2009-03-09 02:48:37 EDT
Created attachment 334468 [details]
Xorg.0.log.old
Comment 3 Pierre Ossman 2009-03-09 02:49:57 EDT
Created attachment 334469 [details]
messages

Last crash happened last night, but it should be easy to find if you look where the kernel booted.
Comment 4 Ben Skeggs 2009-03-09 07:00:18 EDT
Hmm, I'm not seeing anything from the GPU to indicate the driver did anything wrong.  Just to confirm it's a problem with the graphics driver, are you able to switch to the nv or vesa driver and see if you can repeat this with them?
Comment 5 Pierre Ossman 2009-03-10 16:51:33 EDT
I tried nv and I'm unable to provoke it there.
Comment 6 James Cassell 2009-04-17 17:50:46 EDT
this only happens with nouveau; with nv, and the proprietary driver, it doesn't happen.
Comment 7 Pierre Ossman 2009-04-20 02:51:49 EDT
Today the X server crashed instead of locking up. Nothing in the Xorg log unfortunately, and only these lines in messages:

Apr 20 08:47:28 mjolnir kernel: nouveau 0000:01:00.0: Pushbuf config exceeds limits:
Apr 20 08:47:28 mjolnir kernel: nouveau 0000:01:00.0:   dwords : 17447 max 16381
Apr 20 08:47:28 mjolnir kernel: nouveau 0000:01:00.0:   buffers: 2 max 1024
Apr 20 08:47:28 mjolnir kernel: nouveau 0000:01:00.0:   relocs : 4 max 1024
Apr 20 08:47:28 mjolnir kernel: nouveau 0000:01:00.0: nouveau_fifo_free: freeing fifo 2
Apr 20 08:47:29 mjolnir kernel: nouveau 0000:01:00.0: Allocating FIFO number 2
Apr 20 08:47:29 mjolnir kernel: nouveau 0000:01:00.0: nouveau_fifo_alloc: initialised FIFO 2

Since the original report, I've switched to KMS. Perhaps that's why it managed to restart X instead of simply locking up.
Comment 8 Ben Skeggs 2009-04-20 06:05:56 EDT
Wow, I've never seen that trigger before :)  I had a very quick look, one one thing's immediately coming to mind that could cause this to happen, can you try the build at http://koji.fedoraproject.org/scratch/bskeggs/task_1308928/ and see if it helps any?
Comment 9 Pierre Ossman 2009-04-20 13:42:51 EDT
No difference. Same noise in dmesg:

nouveau 0000:01:00.0: Pushbuf config exceeds limits:
nouveau 0000:01:00.0:   dwords : 45904 max 16381
nouveau 0000:01:00.0:   buffers: 2 max 1024
nouveau 0000:01:00.0:   relocs : 4 max 1024
nouveau 0000:01:00.0: nouveau_fifo_free: freeing fifo 2
Comment 10 Ben Skeggs 2009-04-20 19:13:39 EDT
I managed to reproduce it here with a new user, guess my normal theme manages to not trigger this somehow.

Should be fixed as of xorg-x11-drv-nouveau-0.0.12-30.20090421git47bb00f.fc11 (http://koji.fedoraproject.org/koji/taskinfo?taskID=1310297).

Can you confirm it works for you?
Comment 11 Pierre Ossman 2009-04-21 02:28:01 EDT
Seems so. Good work. :)
Comment 12 Ben Skeggs 2009-04-21 07:45:44 EDT
Cool, that's good enough for me!  Closing :)

Thanks for testing!

Note You need to log in before you can comment on or make changes to this bug.