Bug 489110 - memtest-setup should create Memtest86+ entry at end, not at beginning of grub.conf
memtest-setup should create Memtest86+ entry at end, not at beginning of grub...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
: FutureFeature, Reopened
: 451561 (view as bug list)
Depends On: 493681
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 13:13 EST by Andre Robatino
Modified: 2012-03-08 20:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 451561
Environment:
Last Closed: 2012-03-08 20:31:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2009-03-07 13:13:36 EST
Description of problem:
After installing memtest86+ and running memtest-setup, the Memtest86+ entry is
the first entry in grub.conf.  This makes no sense since each time a new kernel
is installed, IT becomes the first entry and all other entries, including the
Memtest86+ one, move down.  Eventually the Memtest86+ entry is below all the
Fedora kernel entries, but above any other OS entries.  It would be more
sensible to place the Memtest86+ entry at the bottom instead, where it would
stay permanently.  Also, a memory check is normally done rarely so it makes more
sense for it to be at the bottom.

Version-Release number of selected component (if applicable):
memtest86+-2.11-3.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1.  Install memtest86+.
2.  Run memtest-setup.

Actual results:
Memtest86+ entry first in grub.conf.

Expected results:
Memtest86+ entry last in grub.conf.
Comment 1 Fedora Admin XMLRPC Client 2009-03-10 21:17:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Orion Poplawski 2009-03-30 18:50:35 EDT
I agree
Comment 3 Paulo Roma Cavalcanti 2009-03-31 09:05:03 EDT
The memtest86+ entry is added using /sbin/grubby

However, I do not see any option in grubby for adding entries
at the end of grub.conf

If anyone tells me how to do it, it will be done,
because I would like, also, to have it at the end of the file.
Comment 4 Andre Robatino 2009-03-31 09:38:36 EDT
Looking at the man page for grubby, it seems that it was intended only for adding and removing kernels, and nothing else, which explains its lack of flexibility (and the --add-kernel and --remove-kernel syntax!).  But the existence of memtest86+ shows that it should be more flexible.  Maybe a bug should be filed against mkinitrd asking for grubby to be enhanced to allow for arbitrary placement (or at least a choice of adding at the top or at the bottom), and once that is done, then /sbin/new-memtest-pkg could be easily modified to make use of it?
Comment 5 Andre Robatino 2009-04-02 12:30:49 EDT
I just created bug #493681 for mkinitrd.  Before doing so I tried installing an old kernel in F10, assuming it would somehow put it in proper order, but it also gets added at the beginning.  So that's another reason for grubby to be more flexible.
Comment 6 Bug Zapper 2009-06-09 07:59:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jarod Wilson 2009-09-17 09:42:06 EDT
*** Bug 451561 has been marked as a duplicate of this bug. ***
Comment 8 Bug Zapper 2010-03-15 08:27:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Anton Arapov 2010-05-03 03:45:23 EDT
...anyone, feel free to reopen and/or work on it, in case you're interested.
Comment 10 Anton Arapov 2011-06-13 03:14:49 EDT
Andre, should we wait a patch from you?
Comment 11 Andre Robatino 2011-06-13 03:37:50 EDT
(In reply to comment #10)
> Andre, should we wait a patch from you?

You said "and/or", so I thought it was okay to reopen it without being able to provide a patch. In any case, if this bug is closed, someone else will probably file another one for the same issue eventually, so it's less work in the long run to just leave the one bug open. The Priority and Severity are both set to "low" which is appropriate.
Comment 13 Andre Robatino 2012-03-08 20:31:53 EST
Closing since this is more or less fixed with grub2. (The memtest86+ entry is below the kernel entries, although above other OS entries.)

Note You need to log in before you can comment on or make changes to this bug.