This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 489120 - (xdg-confused) clicked http links don't open in firefox
clicked http links don't open in firefox
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-07 15:53 EST by sean
Modified: 2009-06-30 11:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 08:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sean 2009-03-07 15:53:54 EST
Description of problem:
Clicking on an html link does not open a browser window.

Version-Release number of selected component (if applicable):
rawhide, updated to today
thunderbird-3.0-1.beta2.fc11.i586
firefox-3.1-0.7.beta2.fc11.i586


How reproducible:
click on a link

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This worked in Alpha 11

System->Preferences->
Preferred Apps has firefox.
Comment 1 John Ellson 2009-03-08 14:19:58 EDT
This should be an F11 blocker!

And please don't ship this version of thunderbird to fc10 .
Comment 2 Tom "spot" Callaway 2009-03-09 09:31:59 EDT
Confirmed. This is rather annoying.
Comment 3 Jan Horak 2009-03-09 11:16:18 EDT
Thanks for your bugreport. Could you send me what do these values contain in following gconf key names, please?
 /desktop/gnome/applications/browser/exec
 /desktop/gnome/url-handlers/https/command
 /desktop/gnome/url-handlers/about/command
 /desktop/gnome/url-handlers/http/command
Comment 4 Tom "spot" Callaway 2009-03-09 11:23:12 EDT
/desktop/gnome/applications/browser/exec = firefox
/desktop/gnome/url-handlers/https/command = firefox %s
/desktop/gnome/url-handlers/about/command = firefox %s
/desktop/gnome/url-handlers/http/command = firefox %s
Comment 5 Matěj Cepl 2009-03-09 12:30:17 EDT
[matej@hubmaier ~]$ gconftool-2 --get /desktop/gnome/applications/browser/exec
firefox
[matej@hubmaier ~]$ gconftool-2 --get /desktop/gnome/url-handlers/https/command
/usr/lib64/firefox-3.0.1/firefox "%s"
[matej@hubmaier ~]$ gconftool-2 --get /desktop/gnome/url-handlers/about/command
firefox %s
[matej@hubmaier ~]$ gconftool-2 --get /desktop/gnome/url-handlers/http/command
firefox %s
[matej@hubmaier ~]$ 

And actually, about: seems to work (at least about:plugins gives a sensible answer)
Comment 6 Matěj Cepl 2009-03-09 12:30:51 EDT
And yes,

[matej@hubmaier ~]$ which firefox
/usr/bin/firefox
[matej@hubmaier ~]$ 

That seems to be correct.
Comment 7 sean 2009-03-09 19:58:37 EDT
I believe t'bird uses /usr/lib/thunderbird-3.0b2/open-browser.sh to open an http link. It looks like t'bird passes the url to open-brower.sh, which uses gnome-open to find the system browser.

But it doesn't:

sh -x open-browser.sh google.com
+ url=google.com
+ '[' -z google.com ']'
+ '[' -f /usr/bin/gnome-open ']'
++ /usr/bin/gnome-open google.com
+ OUTPUT='Error showing url: Error stating file '\''/usr/lib/thunderbird-3.0b2/google.com'\'': No such file or directory'
+ '[' 1 -ne 0 ']'
+ error_exit 'Error showing url: Error stating file '\''/usr/lib/thunderbird-3.0b2/google.com'\'': No such file or directory'
+ echo 'Error showing url: Error stating file '\''/usr/lib/thunderbird-3.0b2/google.com'\'': No such file or directory'
Error showing url: Error stating file '/usr/lib/thunderbird-3.0b2/google.com': No such file or directory
+ '[' -a /usr/bin/zenity ']'
+ /usr/bin/zenity --error '--text=Error showing url: Error stating file '\''/usr/lib/thunderbird-3.0b2/google.com'\'': No such file or directory'
^C

It looks like something's messed up with gnome-open.
Comment 8 Christopher Aillon 2009-03-10 12:00:17 EDT
We probably want to use xdg-open anyway.  Does it work if you change open-browser.sh to use xdg-open instead?
Comment 9 Jan Horak 2009-03-10 12:03:55 EDT
You should call open-browser.sh with full URL, eg: 

 open-browser.sh http://google.com

This is at least in my case working. It looks like TB is not running this script at all. Still investigating...
Comment 10 Tom "spot" Callaway 2009-03-10 12:53:47 EDT
I think Jan is right... I poked this some more today.

I went into the Config Editor for TB (Preferences->Advanced) and looked at "network.protocol-handler.app.http" and "network.protocol-handler.app.https", they were set to "/usr/lib64/thunderbird-3.0b2/open-browser.sh". Just for kicks, I changed them to "/usr/lib64/thunderbird-3.0b2/open-browser.sh %s". Once I'd done that, when I clicked a link, thunderbird prompted me to select an application to open the URL type. I set it to /usr/lib64/thunderbird-3.0b2/open-browser.sh and links now open properly in Firefox.

Applicable only as a workaround, but maybe it will shed some light on the actual problem.
Comment 11 Tom "spot" Callaway 2009-03-10 12:54:55 EDT
Also, noteworthy is that "network.protocol-handler.app.http" and "network.protocol-handler.app.https" are still set to the "/usr/lib64/thunderbird-3.0b2/open-browser.sh %s" value that I overrode them to, even though when it prompted me later, I only put in "/usr/lib64/thunderbird-3.0b2/open-browser.sh". I'm guessing this information is stored somewhere separate... :/
Comment 12 Jan Horak 2009-03-13 12:10:23 EDT
There seems to be missing nsIGnomeVFSService (NS_GNOMEVFSSERVICE_CONTRACTID) in rawhide build. Looks like missing library in BuildRequirement. I will review the building process after the weekend.
Comment 13 Jan Horak 2009-03-17 08:51:51 EDT
Added missing buildrequires and fixed in next release.
Comment 14 sean 2009-03-18 19:14:45 EDT
WFM
thunderbird-3.0-2.beta2.fc11.i586

Note You need to log in before you can comment on or make changes to this bug.