Bug 489129 - lib error on mono-cairo.pc
lib error on mono-cairo.pc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 489130
  Show dependency treegraph
 
Reported: 2009-03-07 17:45 EST by Orcan Ogetbil
Modified: 2009-03-15 08:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-07 18:11:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orcan Ogetbil 2009-03-07 17:45:56 EST
Description of problem:
The file /usr/lib64/pkgconfig/mono-cairo.pc in mono-devel package contains the line
    Libs: -r:${prefix}/lib/mono/1.0/Mono.Cairo.dll
which makes is broken on 64bit systems

Version-Release number of selected component (if applicable):
mono-devel-2.4-8.RC1.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. "yum install mono-devel" on rawhide
  
Actual results:
as explained above

Expected results:
correct path to the Mono.Cairo.dll file
Comment 1 Orcan Ogetbil 2009-03-07 18:01:32 EST
Adding Paul to CC since he solved the same issue in the past.
Comment 2 Paul F. Johnson 2009-03-07 18:11:13 EST
Thanks, though just about anything mono related I get copied into anyway. It's fixed on the next spin
Comment 3 Orcan Ogetbil 2009-03-07 18:19:44 EST
That was quick. Thanks Paul. Sorry if I made you feel overloaded.
Comment 4 Orcan Ogetbil 2009-03-09 21:57:31 EDT
Hi Paul. the same problem exists for mono that is in the F-10 testing repo, and since it is tagged in the buildroot, we can't build gnome-guitar on koji.

I asked releng to remove the tag:
   https://fedorahosted.org/rel-eng/ticket/1322

Could you fix this error on F-10 testing too?
Comment 5 Paul F. Johnson 2009-03-15 08:54:54 EDT
Done. Building and plonking into updates.

Note You need to log in before you can comment on or make changes to this bug.