Bug 489134 - requires gstreamer-python missing
requires gstreamer-python missing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 18:25 EST by Chitlesh GOORAH
Modified: 2009-03-18 15:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.0.3-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 15:15:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2009-03-07 18:25:39 EST
Description of problem:
Requires gstreamer-python is missing

Version-Release number of selected component (if applicable):
Miro-2.0-3.fc10.i386

How reproducible:
Everytime

Steps to Reproduce:
1. yum remove gstreamer-python
2. launch miro
3.
  
Actual results:
chitlesh(~)[0]$miro                                                                                            
2009-03-08 00:15:55,961 INFO     Starting up Miro                                                              
2009-03-08 00:15:55,962 INFO     Version:    2.0                                                               
2009-03-08 00:15:55,969 INFO     OS:         Linux 2.6.27.15-170.2.24.fc10.i686 i686                           
2009-03-08 00:15:55,970 INFO     Revision:   https://svn.participatoryculture.org/svn/dtv/tags/Miro-2.0/tv/resources - 9177                                                                                                   
2009-03-08 00:15:55,971 INFO     Builder:    mockbuild@x86-4.fedora.phx.redhat.com                             
2009-03-08 00:15:55,972 INFO     Build Time: 1235742415.99                                                     
2009-03-08 00:15:55,972 INFO     Starting event loop thread                                                    
2009-03-08 00:15:56,014 INFO     Python version:    2.5.2 (r252:60911, Sep 30 2008, 15:41:38)                  
[GCC 4.3.2 20080917 (Red Hat 4.3.2-4)]                                                                         
2009-03-08 00:15:56,015 INFO     Gtk+ version:      (2, 14, 7)                                                 
2009-03-08 00:15:56,015 INFO     PyGObject version: (2, 15, 4)                                                 
2009-03-08 00:15:56,015 INFO     PyGtk version:     (2, 13, 0)                                                 
2009-03-08 00:15:56,016 INFO     Language:          [('LANG', 'en_US.UTF-8')]                                  
2009-03-08 00:15:56,017 INFO     set_renderer: trying to add gstreamerrenderer                                 
2009-03-08 00:15:56,019 INFO     set_renderer: couldn't load gstreamerrenderer: Traceback (most recent call last):                                                                                                            
  File "/usr/lib/python2.5/site-packages/miro/plat/renderers/__init__.py", line 43, in set_renderer            
    pkg = __import__('miro.plat.renderers.' + modname)                                                         
  File "/usr/lib/python2.5/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 35, in <module>       
    import pygst                                                                                               
ImportError: No module named pygst                                                                             
                                                                                                               
2009-03-08 00:15:56,020 ERROR    init_renderer: error detected...  trying to add gstreamerrenderer             
2009-03-08 00:15:56,021 INFO     set_renderer: trying to add gstreamerrenderer                                 
2009-03-08 00:15:56,022 INFO     set_renderer: couldn't load gstreamerrenderer: Traceback (most recent call last):                                                                                                            
  File "/usr/lib/python2.5/site-packages/miro/plat/renderers/__init__.py", line 43, in set_renderer            
    pkg = __import__('miro.plat.renderers.' + modname)                                                         
  File "/usr/lib/python2.5/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 35, in <module>       
    import pygst                                                                                               
ImportError: No module named pygst                                                                             
                                                                                                               
2009-03-08 00:15:56,031 ERROR    init_renderer: no valid renderer has been loaded                              
2009-03-08 00:15:56,062 INFO     Restoring database...                                                         
2009-03-08 00:15:56,063 INFO     Connecting to /home/chitlesh/.miro/sqlitedb                                   
2009-03-08 00:15:58,679 TIMING   Database load slow: 2.616                                                     
2009-03-08 00:15:58,681 INFO     Database size on disk (in bytes): 6693888                                     
2009-03-08 00:15:58,681 INFO     Database object count: 1114                                                   
2009-03-08 00:15:59,742 TIMING   idle (finish startup) too slow (3.769 secs)                                   
2009-03-08 00:15:59,744 INFO     Checking movies directory '/home/chitlesh/Videos/Miro/'...                    
2009-03-08 00:15:59,786 WARNING  Unknown startup error: Traceback (most recent call last):                     
  File "/usr/lib/python2.5/site-packages/miro/startup.py", line 83, in wrapped                                 
    func(*args, **kwargs)                                                                                      
  File "/usr/lib/python2.5/site-packages/miro/startup.py", line 230, in reconnect_downloaders                  
    item.reconnect_downloaders()                                                                               
  File "/usr/lib/python2.5/site-packages/miro/item.py", line 1467, in reconnect_downloaders                    
    item.setup_links()                                                                                         
  File "/usr/lib/python2.5/site-packages/miro/item.py", line 1261, in setup_links                              
    moviedata.movieDataUpdater.requestUpdate (self)                                                            
  File "/usr/lib/python2.5/site-packages/miro/moviedata.py", line 201, in requestUpdate                        
    self.queue.put(MovieDataInfo(item))                                                                        
  File "/usr/lib/python2.5/site-packages/miro/moviedata.py", line 90, in __init__                              
    fileutil.expand_filename(self.videoPath), fileutil.expand_filename(self.thumbnailPath))                    
  File "/usr/lib/python2.5/site-packages/miro/plat/utils.py", line 292, in movie_data_program_info             
    return app.renderer.movie_data_program_info(moviePath, thumbnailPath)                                      
AttributeError: 'NoneType' object has no attribute 'movie_data_program_info'

2009-03-08 00:16:00,332 TIMING   idle (reconnect downloaders) too slow (0.587 secs)
2009-03-08 00:16:04,159 INFO     Shutting down Downloader...
2009-03-08 00:16:04,160 INFO     Closing Database...
2009-03-08 00:16:09,730 INFO     Shutting down event loop
2009-03-08 00:16:09,733 INFO     Shutting down...
2009-03-08 00:16:09,734 TIMING   idle (shutdown() (using asUrgent)) too slow (5.575 secs)
2009-03-08 00:16:09,735 TIMING   idle (shutdown() (using asUrgent)) cumulative is too slow (5.575 secs)
2009-03-08 00:16:09,737 INFO     Saving preferences...
2009-03-08 00:16:09,738 INFO     Shutting down icon cache updates
2009-03-08 00:16:09,739 INFO     Shutting down movie data updates
2009-03-08 00:16:09,740 INFO     Done shutting down.
2009-03-08 00:16:09,740 INFO     Remaining threads are:
2009-03-08 00:16:09,741 INFO     <_MainThread(MainThread, started)>
Comment 1 Alex Lancaster 2009-03-09 04:27:49 EDT
Definitely looks like a problem, now that gstreamer is the default player backend.  I'll look into adding it, along with trying to fix xine playback.
Comment 2 Fedora Update System 2009-03-09 06:26:34 EDT
Miro-2.0.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/Miro-2.0.2-1.fc10
Comment 3 Fedora Update System 2009-03-09 18:46:55 EDT
Miro-2.0.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2439
Comment 4 Fedora Update System 2009-03-16 06:08:19 EDT
Miro-2.0.3-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/Miro-2.0.3-1.fc10
Comment 5 Fedora Update System 2009-03-16 15:52:06 EDT
Miro-2.0.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2766
Comment 6 Fedora Update System 2009-03-18 15:15:11 EDT
Miro-2.0.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.