Bug 489136 - Automatically grow logical volumes with user input as needed.
Automatically grow logical volumes with user input as needed.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 19:07 EST by Need Real Name
Modified: 2009-09-04 13:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 13:38:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-03-07 19:07:07 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5

During installation, Anaconda can create logical volumes for most common partitions, but it will use remaining space for "/".  Often it's nice to have "/home" on a separate partition, or sometimes less swap space is needed.  Also, using up 100% of a PV means it's impossible to ever use LVM snapshots for anything.

It would be nifty if during installation there was an option to only allocate 10-15G of disk for "/" and leave the remaining free.

As a logical volume would approach being full, the system would automatically* pull from free LVM space and grow the filesystem up to a certain amount.

Either automatically, or with user interaction. 

Reproducible: Always
Comment 1 Matthias Clasen 2009-06-11 14:12:11 EDT
Seems to be an anaconda feature request...
Comment 2 Need Real Name 2009-06-11 15:20:30 EDT
Hi Matthias,

It's partially anaconda, but also with hal and dbus.  If there was free space available on a PV, hal+dbus+an applet could grow a LV as needed by the user, that way /home could be on a separate lv from / or /var/log and grow any LV as needed.

Just an idea. :)
Comment 3 Chris Lumens 2009-09-04 13:38:17 EDT
The custom partitioning interface in anaconda allows you to leave free space available.  You can even have it make the default partitioning scheme, then go in and shrink things down a little bit yourself to leave as much free space as you want.  The rest of this RFE is definitely outside the scope of anaconda, though.  I don't know where to move it to but it should definitely be opened against some other component that actually does things on the running system.

Note You need to log in before you can comment on or make changes to this bug.