Bug 489159 - Can't use "NumLock" in virtual machine running in virt-manager
Can't use "NumLock" in virtual machine running in virt-manager
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 06:49 EDT by David Ye
Modified: 2016-04-26 14:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 10:31:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Ye 2009-03-08 06:49:19 EDT
Description of problem:
In virtual machine running in virt-manager,pressing "NumLock" does not take effect.So I cann't use number keys in keypad to input number.

Version-Release number of selected component (if applicable):
virt-manager-0.6.0-3.fc10.x86_64


How reproducible:
Always

Steps to Reproduce:
1.Create a virtual machine in virt-manager
2.Install Fedora10/RHEL5 in that virtual machine
3.Make sure the numberlock light is on and try to use keypad to input number.

Actual results:
I can not use keypad to input number.It functions as if the number lock is unlocked.

Expected results:
I can use keypad to input number

Additional info:
Comment 1 Perry Myers 2009-03-08 13:37:21 EDT
A few questions... virt-manager is not part of the RHEV Hypervisor product.  Did you discover this bug using the embedded hypervisor or just testing KVM on RHEL5.3?  This bug is most likely either a problem with gtk-vnc/virt-manager/virt-viewer or a problem w/ kvm.

If this problem was discovered using virt-manager in RHEL and can be reproduced on RHEL5.3 w/ kvm package installed, then this should be filed against the RHEL/virt-manager not RHEVH/ovirt-node-image
Comment 2 David Ye 2009-04-03 00:57:00 EDT
It does not appear in virt-manager-0.6.0-5.fc10.x86_64
Comment 4 Cole Robinson 2009-12-02 10:31:18 EST
Comment #2 seems to indicate it can't be reproduced, and I can't reproduce, so closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.