Bug 489199 - Cannot set BOINCOPTS in /etc/sysconfig/boinc
Cannot set BOINCOPTS in /etc/sysconfig/boinc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: boinc-client (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 11:27 EDT by Gilboa Davara
Modified: 2009-03-31 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: 6.4.7-7.r17542svn.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 16:32:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/init.d/boinc_client BOINCOPTS support. (749 bytes, patch)
2009-03-08 11:27 EDT, Gilboa Davara
no flags Details | Diff

  None (edit)
Description Gilboa Davara 2009-03-08 11:27:19 EDT
Created attachment 334438 [details]
/etc/init.d/boinc_client BOINCOPTS support.

As the title suggests, BOINCOPTS parameters in /etc/sysconfig/boinc are over-ridden by /etc/init.d/boinc_client itself.
(Unless I completely misunderstood the difference between init.d/boinc_client, sysconfig/boinc_client and sysconfig/boinc...)

Patch attached.

P.S. Any chance of getting boinc_client into EPEL?

- Gilboa
Comment 1 Milos Jakubicek 2009-03-08 13:44:16 EDT
(In reply to comment #0)
> As the title suggests, BOINCOPTS parameters in /etc/sysconfig/boinc are
> over-ridden by /etc/init.d/boinc_client itself.
> (Unless I completely misunderstood the difference between init.d/boinc_client,
> sysconfig/boinc_client and sysconfig/boinc...)

Thanks for the report, I've modified the init script in a bit different way: 

- the "--dir $BOINCDIR" option should be always passed, hence it was removed from the $BOINCOPTS and put directly in the daemon call.

- setting $BOINCOPTS has been moved before loading the configuration from /etc/sysconfig/boinc-client so that it gets completely overridden by the settings in that file, not only added.

- I've also fixed the init script to actually reflect the sample sysconfig file, which is called boinc-client, not boinc.

> P.S. Any chance of getting boinc_client into EPEL?

Yes, why not...I'll request the EL5 branch.
Comment 2 Gilboa Davara 2009-03-08 14:23:34 EDT
In this case, I'd suggest you use '+=' the sample parameters in sysconfig/boinc_client instead of '=', as people will most likely uncomment the parameters that they require, unaware to the fact that each parameter definition (A=B) over-rides the previous one.

As for the EPEL branch, Thanks! :)

- Gilboa
P.S. I assume that BOINCDIR will also get moved to sysconfig/boinc_client?
Comment 3 Milos Jakubicek 2009-03-08 14:44:22 EDT
(In reply to comment #2)
> In this case, I'd suggest you use '+=' the sample parameters in
> sysconfig/boinc_client instead of '=', as people will most likely uncomment the
> parameters that they require, unaware to the fact that each parameter
> definition (A=B) over-rides the previous one.

No, if they will just uncomment the parameters they'll anyway override all but the last one -- there are always only "=", not "+=" (and the sample file comes from upstream => I'd like to honour it). Hence: no, I want to leave plain "=" there, otherwise it wouldn't be possible to remove some of the options specified in the init script.

> P.S. I assume that BOINCDIR will also get moved to sysconfig/boinc_client?  

That's been already the case, every other variable besides BOINCOPTS has been correctly taken from the sysconfig file, only the BOINCOPTS has been set *after* sourcing the sysconfig file, hence it overrode it (this was because it had BOINCDIR as a part, but this has been now removed and solved hereby).
Comment 4 Milos Jakubicek 2009-03-09 14:01:32 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > P.S. Any chance of getting boinc_client into EPEL?
> 
> Yes, why not...I'll request the EL5 branch.  

FYI: I've tried to build for EL5, but there is too old libcurl:

checking for the version of libcurl... 7.15.5
checking for libcurl >= version 7.17.1... no
configure: error:

=> we have to wait for RHEL having new enough libcurl :(
Comment 5 Fedora Update System 2009-03-09 18:44:45 EDT
boinc-client-6.4.7-2.r17542svn.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update boinc-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2428
Comment 6 Fedora Update System 2009-03-09 19:10:15 EDT
boinc-client-6.4.7-2.r17542svn.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update boinc-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2560
Comment 7 Gilboa Davara 2009-03-10 06:36:47 EDT
OK. I'll stick to the binary version until RHEL gets released.

- Gilboa
Comment 8 Gilboa Davara 2009-03-10 06:43:42 EDT
(Thanks!)
Comment 9 Fedora Update System 2009-03-18 14:54:55 EDT
boinc-client-6.4.7-5.r17542svn.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update boinc-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2560
Comment 10 Fedora Update System 2009-03-18 14:58:46 EDT
boinc-client-6.4.7-5.r17542svn.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update boinc-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2428
Comment 11 Fedora Update System 2009-03-31 16:32:12 EDT
boinc-client-6.4.7-8.r17542svn.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-03-31 16:33:38 EDT
boinc-client-6.4.7-7.r17542svn.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.