Bug 489204 - Memory leak with regex in 5.10.0
Memory leak with regex in 5.10.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 11:59 EDT by smallpond
Modified: 2009-04-21 21:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.10.0-68.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 10:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description smallpond 2009-03-08 11:59:53 EDT
Description of problem:

A memory leak which was reported fixed in perl 5.10.0.17, Oct 2008,
http://rt.perl.org/rt3/Public/Bug/Display.html?id=59516
still exists in the Fedora 10 rpm.
The problem is with non-constant regexes that use single-character classes.

Version-Release number of selected component (if applicable):

perl-5.10.0-56.fc10.i386 built 16 Feb 2009

How reproducible:

easily.

Steps to Reproduce:
1. Run the program on the linked page.
2. Watch with ps.
  
Actual results:

Memory usage grows continually.

Expected results:

Memory usage stays more-or-less constant.

Additional info:
Comment 1 Marcela Mašláňová 2009-03-11 08:36:29 EDT
Thank you for your report. This fix need to pick up more patches from git. It takes some time.
Comment 2 Tom "spot" Callaway 2009-03-11 14:23:09 EDT
I'm working on this in rawhide, it should be trivial to push the changes back to F-9/F-10.
Comment 3 Tom "spot" Callaway 2009-03-11 18:31:37 EDT
There are patches checked into CVS for this in F-9, F-10, and devel. Updates will have to wait for everyone to be okay with the reordering of @INC (bz 489221).
Comment 4 Fedora Update System 2009-03-23 11:54:40 EDT
perl-5.10.0-42.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/perl-5.10.0-42.fc9
Comment 5 Fedora Update System 2009-03-23 13:22:25 EDT
perl-5.10.0-63.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/perl-5.10.0-63.fc10
Comment 6 Marcela Mašláňová 2009-03-24 10:48:35 EDT
perl-5.10.0-63.fc10  and perl-5.10.0-42.fc9   fix this issue.
Comment 7 Fedora Update System 2009-04-21 20:54:23 EDT
perl-5.10.0-68.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-04-21 21:08:03 EDT
perl-5.10.0-68.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.