This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 489231 - move drpmsync to a subpackage
move drpmsync to a subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: deltarpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
Depends On: F11MinimalPlatform
Blocks: F11Target FedoraOLPCDelta FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2009-03-08 18:10 EDT by Peter Robinson
Modified: 2009-04-22 10:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 01:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-03-08 18:10:18 EDT
drpmsync is written in perl and looks to provide extra functionality than it required in standard client update stuff. It would be great to move it to a sub package and hence move the perl requirement to the subpackage. This will allow smaller distros to remove perl.
Comment 1 Peter Robinson 2009-04-19 17:02:38 EDT
Ping? Without the change we're stripping this out of the OLPC with GNOME desktop build because of the perl dep which takes PackageKit with it. Not ideal but perl adds around 10% to the OLPC build.
Comment 2 Jonathan Dieter 2009-04-22 01:56:04 EDT
Sorry for the delay.  Done.  See http://koji.fedoraproject.org/koji/taskinfo?taskID=1313930.  If you want me to build for any of the other releases, please let me know.
Comment 3 Peter Robinson 2009-04-22 04:20:30 EDT
Would be great if it could be tagged into F11. Means we can add PackageKit back into the OLPC Gnome stuff :)
Comment 4 Jonathan Dieter 2009-04-22 09:54:16 EDT
It just got tagged into dist-f11.  Thank rel-eng!
Comment 5 Peter Robinson 2009-04-22 10:34:53 EDT
Thanks to all :)

Note You need to log in before you can comment on or make changes to this bug.