Bug 489238 - yum bails out in a cleanup with "TypeError: string indices ..." leading to a small disaster
yum bails out in a cleanup with "TypeError: string indices ..." leading to a ...
Status: CLOSED DUPLICATE of bug 488994
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 21:03 EDT by Michal Jaegermann
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 00:13:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of running 'rpm -V <package>' for packages from the latest yum transaction (474.76 KB, text/plain)
2009-03-08 21:03 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2009-03-08 21:03:14 EDT
Created attachment 334455 [details]
results of running 'rpm -V <package>' for packages from the latest yum transaction

Description of problem:

Applying 20090308 rawhide updates I got:
...
  Cleanup        : policycoreutils                                        39/48 
restorecond: unrecognized service
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 389, in callback
    self._scriptError(bytes, total, h)
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 510, in _scriptError
    pkgtup = self._dopkgtup(hdr)
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 237, in _dopkgtup
    tmpepoch = hdr['epoch']
TypeError: string indices must be integers, not str
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0x1c04950>> failed, aborting!

It turned out that yum already removed libgcc-4.4.0-0.22.x86_64 but despite that yum log file says "Mar 08 16:35:53 Updated: libgcc-4.4.0-0.23.x86_64" those files were not there and the next invocation of yum, and rpm, ended up with:

   libgcc_s.so.1: cannot open shared object file: No such file or directory

After fixing that, by rebooting to something else and using rpm2cpio there
to put libraries in place, I tried 'yum-complete-transaction'.  That erased
a bunch of packages from a missing "cleanup".  One remaining issue - none
of freshly installed packages, with an exception of libgcc-4.4.0-0.23.x86_64 which I had to fix beforehand in order to proceed, passed 'rpm -V ...' test. Results of such attempt are attached.

Is this caused by a yum failure as above or the second part is another issue related to bug 489235?
   
Version-Release number of selected component (if applicable):
yum-3.2.21-12.fc11.noarch

How reproducible:
I do not know yet.  It is somewhat difficult to repeat without seriously messing the whole system.
Comment 1 seth vidal 2009-03-09 00:13:47 EDT

*** This bug has been marked as a duplicate of bug 488994 ***

Note You need to log in before you can comment on or make changes to this bug.