Bug 489243 - duplicate footnotes in PDF
duplicate footnotes in PDF
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Forte
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-08 22:55 EDT by Darrin Mison
Modified: 2014-06-18 03:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-05 20:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darrin Mison 2009-03-08 22:55:39 EDT
Description of problem:
If the same URL is repeated on a page it produces two identical footnotes.  It would be nice if Publican could detect this and reuse the first footnote for the subsequent ones.

Version-Release number of selected component (if applicable):
0.42

How reproducible:
Everytime

Steps to Reproduce:
1.  Add two <ulink> elements that point to the same URL so they will appear on the same page.
2. Generate pdf
  
Actual results:
Two identical footnotes are produced 

Expected results:
One footnote referred to by both.

Additional info:
The docbook element <footnoteref> may be useful here.
Comment 1 Darrin Mison 2009-03-09 02:47:13 EDT
by "nice" I mean "professional-looking" ;-)
Comment 2 Darrin Mison 2009-04-05 20:42:13 EDT
It would also be great if a similar idea could be applied to all footnotes.  ie. if the content is identical and they are being rendered for the same page.
Comment 3 Jeff Fearn 2009-04-05 20:48:29 EDT
This behaviour would need to be done in FOP because publican can't know if two links are on the same page since the page is laid out by FOP.

Note You need to log in before you can comment on or make changes to this bug.