Bug 489294 - Review Request: icc_examin - ICC profile viewer and color visualization
Review Request: icc_examin - ICC profile viewer and color visualization
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 07:35 EDT by Nicolas Chauvet (kwizart)
Modified: 2009-03-13 07:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 07:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-03-09 07:35:19 EDT
Spec URL:
http://kwizart.fedorapeople.org/SPECS/icc_examin.spec
SRPM URL:
http://kwizart.fedorapeople.org/SRPMS/icc_examin-0.46-1.fc10.src.rpm
Description: ICC profile viewer and colour visualisation
Comment 1 Nicolas Chauvet (kwizart) 2009-03-09 07:51:07 EDT
Updated description to American English
Description: ICC profile viewer and color visualization

This package Requires the lastest oyranos 0.1.9 (built today in Rawhide) and elektra 0.7.0. Thus I cannot plan to have this version earlier than F-11.

Patches are been send upstream.
Comment 2 Nicolas Chauvet (kwizart) 2009-03-09 08:02:08 EDT
Built on today's Rawhide
http://koji.fedoraproject.org/koji/taskinfo?taskID=1231385
Comment 3 Parag AN(पराग) 2009-03-10 06:30:32 EDT
unable to install see some deps problem in rawhide.
I can't update new oyranos in rawhide.

also you should use 
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
Comment 4 Nicolas Chauvet (kwizart) 2009-03-10 07:27:08 EDT
(In reply to comment #3)
> unable to install see some deps problem in rawhide.
> I can't update new oyranos in rawhide.
You need this build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=93406
> also you should use 
> make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"  
fixed in my local copy. It works, indeed.
Comment 5 Parag AN(पराग) 2009-03-10 09:05:01 EDT
I mean to write when I try to install oyranos-0.1.9-2.fc11.i586.rpm

error: Failed dependencies:
	color-filesystem is needed by oyranos-0.1.9-2.fc11.i586
	elektra-kdb is needed by oyranos-0.1.9-2.fc11.i586
	libXNVCtrl.so.0 is needed by oyranos-0.1.9-2.fc11.i586
Comment 6 Nicolas Chauvet (kwizart) 2009-03-10 09:43:18 EDT
(In reply to comment #5)
> I mean to write when I try to install oyranos-0.1.9-2.fc11.i586.rpm
> 
> error: Failed dependencies:
>  color-filesystem is needed by oyranos-0.1.9-2.fc11.i586
>  elektra-kdb is needed by oyranos-0.1.9-2.fc11.i586
>  libXNVCtrl.so.0 is needed by oyranos-0.1.9-2.fc11.i586  
From my own ISP nearest mirror:
ftp://ftp.proxad.net/mirrors/fedora.redhat.com/fedora/linux/development/x86_64/os/Packages/color-filesystem-1-5.noarch.rpm
ftp://ftp.proxad.net/mirrors/fedora.redhat.com/fedora/linux/development/x86_64/os/Packages/libXNVCtrl-169.12-3.fc11.i586.rpm
The second one was a misstake indeed, fixed in new oyranos build
http://koji.fedoraproject.org/koji/taskinfo?taskID=1234744
Comment 7 Parag AN(पराग) 2009-03-12 03:09:10 EDT
Review:
+ package builds in mock (rawhide i386).
koji Build => http://koji.fedoraproject.org/koji/taskinfo?taskID=1231385
+ rpmlint output for SRPM and for RPM is silent.
+ source files match upstream url
01b8a19489601850192476a06393cf47  icc_examin-0.46.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ translations are available
+ Does owns the directories it creates.
+ update-mime-database,update-desktop-database scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Desktop file installed correctly.
+ GUI app.
+ Package icc_examin-0.46-1.fc11.i586 =>
Provides: mimehandler(application/x-cgats) mimehandler(application/x-icc) mimehandler(model/vrml) mimehandler(x-world/x-vrml)

Requires: libGL.so.1 libGLU.so.1 libX11.so.6 libXext.so.6 libXinerama.so.1 libXpm.so.4 libXxf86vm.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3) libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) libdl.so.2 libelektra.so.3 libfltk.so.1.1 libfltk_gl.so.1.1 libfltk_images.so.1.1 libfreetype.so.6 libftgl.so.0 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libjpeg.so.62 liblcms.so.1 libm.so.6 libm.so.6(GLIBC_2.0) libm.so.6(GLIBC_2.1) liboyranos.so.0.1.9 libpng12.so.0 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libstdc++.so.6 libstdc++.so.6(CXXABI_1.3) libstdc++.so.6(GLIBCXX_3.4) libstdc++.so.6(GLIBCXX_3.4.11) libstdc++.so.6(GLIBCXX_3.4.9) libxml2.so.2 libz.so.1 rtld(GNU_HASH)

APPROVED.
Comment 8 Nicolas Chauvet (kwizart) 2009-03-12 04:55:49 EDT
New Package CVS Request
=======================
Package Name: icc_examin
Short Description: ICC profile viewer and color visualization
Owners: kwizart
Branches: devel
Cvsextras Commits: yes
Comment 9 Kevin Fenzi 2009-03-12 22:52:46 EDT
cvs done.

Note You need to log in before you can comment on or make changes to this bug.