Bug 489321 - cannot unlock encrypted /home
cannot unlock encrypted /home
Status: CLOSED DUPLICATE of bug 489146
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 10:11 EDT by Eric Paris
Modified: 2009-03-09 10:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 10:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2009-03-09 10:11:16 EDT
plymouth-0.7.0-0.2009.03.06.fc11.i586

I am unable to unlock my encrypted /home partition.  / is NOT encrypted.  I boot in text mode, kms does not work with this video card.

Things act a bit differently depending on if I hit 'esc' before it requests my password.  If I do not hit escape I get the prompt at the bottom of the screen (not cleanly in the the middle like I expect.)  When I type my pword I get *** like I expect.  When I hit enter at the end it just sorta sits there.  If I hit escape at that point it complains about a bad file descripter switching to some boot splash screen.  If I hit esc again it starts moving again, but fails to mount /home since it wasn't unencrypted and drops into maint.  I cannot enter my pword in the maintenence window, since every key stroke causes the request for pword to appear on a new line.

If I hit esc very early I get something a bit different.  When I type my pword it actually appears on the screen.  When I hit enter it say "*error: unexpectedly disconnected from boot status daemon" and it continues to boot.  It fails and drops into maint mode.  In this case I am able to enter my root pw.  Thankfully this allows me to edit my /etc/fstab and remove /home so I can at least start the machine.

I downgraded plymouth to plymouth-0.6.0-3.fc11.i586 and installed a new kernel which should have built and all new initrd.  This worked fine.
Comment 1 Ray Strode [halfline] 2009-03-09 10:23:57 EDT

*** This bug has been marked as a duplicate of bug 489146 ***

Note You need to log in before you can comment on or make changes to this bug.