Bug 489366 - Kaffeine crashs on quit after beeing used
Kaffeine crashs on quit after beeing used
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kaffeine (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 13:54 EDT by Florian Sievert
Modified: 2009-03-09 15:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 15:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Sievert 2009-03-09 13:54:08 EDT
Description of problem:
Kaffeine crashs on quit after playing a video or a music file.

Version-Release number of selected component (if applicable):
kaffeine.i386                                                                  0.8.7-3.fc10                                                        installed
kaffeine-debuginfo.i386                                                        0.8.7-3.fc10                                                        installed
kaffeine-libs.i386                                                             0.8.7-3.fc10                                                        installed

How reproducible:
Always

Steps to Reproduce:
1. Start kaffeine
2. Play either a video or music file
3. Use File->Quit
  
Actual results:
A Krash report is beeing shown caused by an signal 11 (SIGSEGV).

Expected results:
The application is terminated quitely

Additional info:
The problem seems to not appear, if the application quit without playing anything. The profile of kaffeine was deleted. SELinux is deactivated. The output of krash is added bellow. The debuginfo of kaffeine is installed, however the trace does not seems to be useful. If you can point to other missing debuginfo packages that might be missing, I will install it in order to get a more usefill backtrace. In the german forum another user complains about a similar problem, however he does not get a krash dialog. Another user have problem with k3b. So it might be related to kde 3.5 applications, however we wasn't able to reproduce the problem, so I just fill a bug again the sigsegv that us reproducable on my system.

[Thread debugging using libthread_db enabled]
[New Thread 0xb7fd5700 (LWP 8308)]
0x00e60416 in __kernel_vsyscall ()
[Current thread is 1 (Thread 0xb7fd5700 (LWP 8308))]

Thread 1 (Thread 0xb7fd5700 (LWP 8308)):
#0  0x00e60416 in __kernel_vsyscall ()
#1  0x006aa456 in nanosleep () from /lib/libc.so.6
#2  0x006aa26e in sleep () from /lib/libc.so.6
#3  0x074e0ada in KCrash::startDrKonqi () from /usr/lib/libkdecore.so.4
#4  0x074e7600 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#5  <signal handler called>
#6  0x020b6504 in ?? () from /lib/libselinux.so.1
#7  0x020af6be in ?? () from /lib/libselinux.so.1
#8  0x020a7d08 in selinux_file_context_cmp () from /lib/libselinux.so.1
#9  0x020beed4 in selinux_file_context_cmp () from /lib/libselinux.so.1
#10 0x007c9de0 in __JCR_LIST__ () from /lib/libpthread.so.0
#11 0xbfd04068 in ?? ()
#12 0x020a7caa in selinux_file_context_cmp () from /lib/libselinux.so.1
#13 0x020beff4 in selinux_file_context_cmp () from /lib/libselinux.so.1
#14 0x00000000 in ?? ()

Console output is just:
KCrash: Application 'kaffeine' crashing...
Comment 1 Rex Dieter 2009-03-09 14:01:01 EDT
Is xine-lib-extras-freeworld installed? 

If so, it's a known (non-fedora) issue (related to ffmpeg, probably).


Are you using a kde desktop?  gnome?  what version?
Comment 2 Florian Sievert 2009-03-09 15:14:25 EDT
Yes, xine-lib-extras-freeworld is installed. So again a xine-problem? If yes, it is really frustrating. Even if it is not officially supported there seems to be quite some packages that seems to cause plenty of hurt. It is really giving fedora a bad image, if there are application that are not starting (xine itself) or causing such crashs. The problem was noticed in a forum and takes some people quite busy to localize the orgin of it. This is even more sad, cause it is hitting packages that are not yet ready for kde4. Another user also got the same problem with k3b. I might not be reproducable, because I didn't install support for k3b/mp3.

I am on kde desktop from kde-redhat:
kdebase.i386                                                                       6:4.2.1-2.fc10                                                installed
kdebase-libs.i386                                                                  6:4.2.1-2.fc10                                                installed
kdebase-runtime.i386                                                               4.2.1-2.fc10                                                  installed
kdebase-runtime-libs.i386                                                          4.2.1-2.fc10                                                  installed
kdebase-workspace.i386                                                             4.2.1-4.fc10                                                  installed
kdebase-workspace-libs.i386                                                        4.2.1-4.fc10                                                  installed
The other user should be uptodate with the current official fedora version.
Comment 3 Rex Dieter 2009-03-09 15:21:19 EDT
While frustrating, I hardly consider "crashing on quit" to equate to anything close to "plenty of hurt".

Anyway, there's already a bug open @ bugzilla.rpmfusion.org... I can dig it up for you if you like.

(closing->notabug since it's due to software not shipped by the fedora project).
Comment 4 Rex Dieter 2009-03-09 15:22:44 EDT
and for what's worth, the 'xine crashing on start' issue should be resolved by now (as far as I know, xine-lib contains was fixed to workaround that particular issue).
Comment 5 Rex Dieter 2009-03-09 15:24:02 EDT
sorry for the bz spam... but k3b crashing on quit seems to be precisely the same issue... it's kde3 apps linked against ffmpeg that seem to be most affected.
Comment 6 Florian Sievert 2009-03-09 15:33:15 EDT
Yes, it is the same issue. Alright, then moving the problem to rpmfusion ...
https://bugzilla.rpmfusion.org/show_bug.cgi?id=359

Note You need to log in before you can comment on or make changes to this bug.