Bug 489380 - displayBySerial throws bad error message on unknown serial numbers
displayBySerial throws bad error message on unknown serial numbers
Status: CLOSED DUPLICATE of bug 553423
Product: Dogtag Certificate System
Classification: Community
Component: CA (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Wnuk
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-03-09 15:35 EDT by Rob Crittenden
Modified: 2015-01-04 18:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 18:07:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2009-03-09 15:35:29 EDT
Description of problem:

Retrieve an unknown serial number using:

https://ca.example.com:9444/ca/ee/ca/displayBySerial?serialNumber=0xb

and the result is a page containing the error message:

LDAP operation failure - cn=11,ou=certificateRepository, ou=ca, dc=ca.example.com-pki-ca netscape.ldap.LDAPException: error result (32); matchedDN = ou=certificaterepository,ou=ca,dc=ca.example.com-pki-ca

Version-Release number of selected component (if applicable):

svn checkout r276

Steps to Reproduce:

Request a certificate to be displayed for a non-existent serial #
  
Expected results:

A status message saying "this certificate does not exist" or something of the sort.
Comment 1 Andrew Wnuk 2009-03-17 18:07:52 EDT
I used CA installed on Fedora 8 and FireFox 2.0.0.19 to test the following combinations:

  https://<hostname>:9444/ca/ee/ca/displayBySerial?serialNumber=0xb
  https://<hostname>:9444/ca/ee/ca/displayBySerial?serialNumber=11

  http://<hostname>:9180/ca/ee/ca/displayBySerial?serialNumber=0xb
  http://<hostname>:9180/ca/ee/ca/displayBySerial?serialNumber=11

  https://<hostname>:9443/ca/agent/ca/displayBySerial?serialNumber=0xb
  https://<hostname>:9443/ca/agent/ca/displayBySerial?serialNumber=11

and they all work.
Comment 2 Rob Crittenden 2009-03-17 18:24:44 EDT
Worked how? What message did you get back? Is there an existing cert with that serial number?
Comment 3 Andrew Wnuk 2010-05-11 19:50:07 EDT

*** This bug has been marked as a duplicate of bug 553423 ***

Note You need to log in before you can comment on or make changes to this bug.