Bug 489387 - Installing a package w/ a remote command fails
Installing a package w/ a remote command fails
Status: CLOSED DUPLICATE of bug 529359
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Partha Aji
wes hayutin
http://grandprix.rhndev.redhat.com/rh...
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 16:02 EDT by wes hayutin
Modified: 2010-04-12 13:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 14:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
run remote command during a package install (164.00 KB, image/png)
2009-09-08 10:03 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-09 16:02:03 EDT
Description of problem:

Satellite-5.3.0-RHEL5-re20090306.2-i386-embedded-oracle.iso

1. register a system
2. enable rhncfg mang, and rhn-actions-control enable-all
3. use the webui to install zsh and schedule a remote command before the package is installed..

my command was
#!/bin/bash
uname -a
ls
hostname


4. run rhn_check -vvv from the client

results: package fails to install..
System	Failed	Message
fjs-0-18.rhndev.redhat.com 	3/9/09 3:56:10 PM EDT 	invalid action 1272 for server 1000010295 

expected results:
command executes
package installs
Comment 1 Partha Aji 2009-03-19 16:35:42 EDT
Should be fixed in the next iso...
Comment 2 Partha Aji 2009-03-31 16:05:51 EDT
Mass Move to ON_QA
Comment 3 wes hayutin 2009-04-02 13:02:43 EDT
fails..

recreate.
1. verify remote command works first.
2. schedule a simple remote command, rhn_check (something like  ls -la )

3. schedule package install of zsh w/ remote command ( ls -la)
4. rhn_check

script fails, package installation fails..
bug fails =)


This action's status is: Failed.
The client picked up this action on 04/ 2/09 12:53:47 PM EDT.
The client completed this action on 04/ 2/09 12:53:48 PM EDT.
Client execution returned "Script failed" (code 1)


Run as: root:root
Timeout: 600 seconds

#!/bin/sh
ls


Start Date: 2009-04-02 12:53:47
End Date: 2009-04-02 12:53:47
Return Code: 256
Raw Output: view/download raw script output
Filtered Output:

[Thu Apr  2 13:01:34 2009] up2date D: Sending back response (1, 'Script failed',
 {'output': '', 'base64enc': 1, 'process_end': '2009-04-02 13:01:33', 'return_co
de': 256, 'process_start': '2009-04-02 13:01:33'})
[Thu Apr  2 13:01:37 2009] up2date D: do_call packages.checkNeedUpdate ('rhnsd=1
',)
[Thu Apr  2 13:01:37 2009] up2date D: local action status:  (0, 'rpm database no
t modified since last update (or package list recently updated)', {})
(END) 


tested on 4/1 build
Comment 4 wes hayutin 2009-04-08 16:50:13 EDT
verified on 4/3
Comment 5 Jan Pazdziora 2009-09-07 05:59:33 EDT
Can you please clarify how I should achieve the "use the webui to install zsh and schedule a remote command before the package is installed.." step of the test plan?

I was able to schedule package installation, scheduled as soon as possible. I was able to schedule remote command execution. I set the remote command execution "in the past" but when I run rhn_check -vv, the package installation is run first, then the command execution. The time that I set is clearly taken to mean the limit before which the event is not considered, but it does not enforce the ordering.

So, how do i schedule the remote command before the package installation?
Comment 6 wes hayutin 2009-09-08 08:44:11 EDT
when installing a package you have an option to run a remote command and install.
Comment 7 Jan Pazdziora 2009-09-08 09:02:02 EDT
(In reply to comment #6)
> when installing a package you have an option to run a remote command and
> install.  

Can you point me to where exactly I find the option? I go from system's overview page to Software -> Packages -> Install, I check the checkbox next to the package and click Install Selected Packages. On the next page I click Confirm. The only additional option I can see is Schedule action as soon as possible or Schedule action for no sooner than: <date selection>.
Comment 8 wes hayutin 2009-09-08 10:02:55 EDT
looks like the function has been improperly removed from 530
Comment 9 wes hayutin 2009-09-08 10:03:44 EDT
Created attachment 360080 [details]
run remote command during a package install 

https://test10-64.rhndev.redhat.com/rhn/systems/details/packages/InstallConfirm.do?sid=1000011407
Comment 10 wes hayutin 2009-09-08 10:09:08 EDT
the above screen shot was taken from a 520 sat.
Comment 12 Brandon Perkins 2009-09-08 13:07:01 EDT
Reopening and moving to sat531-triage to get traction on this.

Note You need to log in before you can comment on or make changes to this bug.