Bug 489414 - lara java applet does not work
lara java applet does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jon VanAlten
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 18:11 EDT by Martin Jürgens
Modified: 2009-09-15 03:45 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.6.0.0-29.b16.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 03:45:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2009-03-09 18:11:54 EDT
Description of problem:
the lara java applet located here: https://lara06.rz9.hetzner.de/auth.asp does not work using openjdk. it works fine with the sun jre.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-plugin-1.6.0.0-9.b14.fc10.i386

How reproducible:
always
Comment 1 Deepak Bhole 2009-04-23 18:04:44 EDT
That page doesn't load any more. Is there another URL I can try?
Comment 2 Martin Jürgens 2009-07-15 07:41:47 EDT
please note that the link given is available again.
Comment 3 Deepak Bhole 2009-07-27 15:07:39 EDT
Thanks. I can reproduce this. Looking into it now.
Comment 4 Deepak Bhole 2009-07-27 15:53:10 EDT
Okay, I have found the problem. This is a problem with the site certificate. The CN for the certificate offered by the site is "Raritan" and the host name is "lara06.rz9.hetzner.de". 

The Sun plugin allows bypassing this. We do not. This is a bug on our side though, as we should be giving users that option.
Comment 5 Jon VanAlten 2009-08-05 11:15:43 EDT
Trying to test this, but page not loading.
Comment 6 Jon VanAlten 2009-08-05 11:19:36 EDT
Disregard previous if you like; since the issue is identified I will make a local test case.
Comment 7 Jeff White 2009-08-17 23:16:11 EDT
I have a similar issue on F11.


steps to reproduce

1) http://www.java.com/en/download/help/testvm.xml



regards
Jeff
Comment 8 Deepak Bhole 2009-08-18 11:28:46 EDT
The problem with the site specified in Comment #7 is not related to the plugin. The exception trace shows:

java.lang.StringIndexOutOfBoundsException: String index out of range: 8
    at java.lang.String.substring(String.java:1946)
    at testvm2.Main.init(Main.java:79)
    at sun.applet.AppletPanel.run(AppletPanel.java:436)
    at java.lang.Thread.run(Thread.java:636)

That implies a problem in the Applet code. My guess is that they are assuming that the name+version string would would be what the Sun plugin provides, and since the IcedTea provided string is different, it goes out of bounds.
Comment 9 Fedora Update System 2009-09-11 09:30:25 EDT
java-1.6.0-openjdk-1.6.0.0-21.b16.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-21.b16.fc10
Comment 10 Fedora Update System 2009-09-11 09:32:53 EDT
java-1.6.0-openjdk-1.6.0.0-29.b16.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-29.b16.fc11
Comment 11 Fedora Update System 2009-09-15 03:44:46 EDT
java-1.6.0-openjdk-1.6.0.0-21.b16.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-09-15 03:45:42 EDT
java-1.6.0-openjdk-1.6.0.0-29.b16.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.