Bug 489415 - Snapsot rollbacks, perl ISE after clicking on snapshot tags, and trying to rollback
Snapsot rollbacks, perl ISE after clicking on snapshot tags, and trying to ro...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
http://grandprix.rhndev.redhat.com/ne...
:
Depends On:
Blocks: sat530-snapshots
  Show dependency treegraph
 
Reported: 2009-03-09 18:18 EDT by wes hayutin
Modified: 2009-09-10 15:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-09 18:18:47 EDT
Description of problem:

Satellite-5.3.0-RHEL5-re20090306.2-i386-embedded-oracle.iso

recreate:
1. register system, enable provisioning
2. click snapshot tag

first time I clicked I received

ndler.pm 124 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Mon Mar 09 17:32:57 2009] [error] Traceback sent to whayutin@redhat.com at /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm line 729.
RHN 3166 2009/03/09 17:49:40 -04:00: ('Server not subscribed to any channels', 1000010371)
RHN 2694 2009/03/09 17:49:45 -04:00: ('Server not subscribed to any channels', 1000010371)
RHN 3168 2009/03/09 17:49:50 -04:00: ('Server not subscribed to any channels', 1000010371)
RHN 2726 2009/03/09 17:49:55 -04:00: ('Server not subscribed to any channels', 1000010371)
RHN 2690 2009/03/09 17:50:00 -04:00: ('Server not subscribed to any channels', 1000010371)
[Mon Mar 09 18:10:52 2009] [error] Execution of /var/www/html/network/systems/details/history/snapshots/system_tags.pxt failed at Mon Mar  9 18:10:52 2009: RHN::Exception: DBD::Oracle::st execute failed: ORA-12801: error signaled in parallel query server P002\nORA-01008: not all variables bound (DBD ERROR: OCIStmtExecute) [for Statement "\n  SELECT SGT.id, SEV.label, SEV.server_group_type_id, SEV.permanent, SEV.is_base\n    FROM rhnServerEntitlementView SEV, rhnServerGroupType SGT\n   WHERE SEV.server_id = :sid\n     AND SGT.label = SEV.label\nORDER BY SEV.label\n  " with ParamValues: :sid="1000010380"]\n  RHN::DB /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm 237 RHN::Exception::DB::throw\n  RHN::DB::st /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm 561 RHN::DB::handle_error\n  RHN::DB::DataSource /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/DataSource.pm 75 RHN::DB::st::execute_h\n  RHN::DataSource /usr/lib/perl5/vendor_perl/5.8.8/RHN/DataSource.pm 133 RHN::DB::DataSource::run_query\n  RHN::DB::Server /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/Server.pm 2236 RHN::DataSource::execute_query\n  RHN::DB::Server /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/Server.pm 2246 RHN::DB::Server::entitlements\n  RHN::DB::Server /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/Server.pm 577 RHN::DB::Server::has_entitlement\n  RHN::Access /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm 304 RHN::DB::Server::has_virtualization_entitlement\n  PXT::ACL /usr/lib/perl5/vendor_perl/5.8.8/PXT/ACL.pm 94 RHN::Access::system_has_virtualization_entitlement_acl_test\n  Sniglets::Navi::Node /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi/Node.pm 185 PXT::ACL::eval_acl\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi.pm 202 Sniglets::Navi::Node::visible\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi.pm 168 Sniglets::Navi::render_nav\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi.pm 128 Sniglets::Navi::format_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.8.8/PXT/Parser.pm 152 Sniglets::Navi::navi_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.8.8/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 632 PXT::Parser::expand_tags\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 124 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 124 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Mon Mar 09 18:10:53 2009] [error] Traceback sent to whayutin@redhat.com at /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm line 729.


I was able to go get back into a sane state..
3. created a snapshot tag
4. install a couple packages
5. click snapshot tag, and try to roll back to origianal tag

get 

[Mon Mar 09 18:14:55 2009] [error] Execution of /var/www/html/network/systems/details/history/pending.pxt failed at Mon Mar  9 18:14:55 2009: RHN::Exception: DBD::Oracle::st execute failed: ORA-12801: error signaled in parallel query server P003\nORA-01008: not all variables bound (DBD ERROR: OCIStmtExecute) [for Statement "\n  SELECT SGT.id, SEV.label, SEV.server_group_type_id, SEV.permanent, SEV.is_base\n    FROM rhnServerEntitlementView SEV, rhnServerGroupType SGT\n   WHERE SEV.server_id = :sid\n     AND SGT.label = SEV.label\nORDER BY SEV.label\n  " with ParamValues: :sid="1000010380"]\n  RHN::DB /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm 237 RHN::Exception::DB::throw\n  RHN::DB::st /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm 561 RHN::DB::handle_error\n  RHN::DB::DataSource /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/DataSource.pm 75 RHN::DB::st::execute_h\n  RHN::DataSource /usr/lib/perl5/vendor_perl/5.8.8/RHN/DataSource.pm 133 RHN::DB::DataSource::run_query\n  RHN::DB::Server /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/Server.pm 2236 RHN::DataSource::execute_query\n  RHN::DB::Server /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/Server.pm 2246 RHN::DB::Server::entitlements\n  RHN::DB::Server /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/Server.pm 577 RHN::DB::Server::has_entitlement\n  RHN::Access /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm 304 RHN::DB::Server::has_virtualization_entitlement\n  PXT::ACL /usr/lib/perl5/vendor_perl/5.8.8/PXT/ACL.pm 94 RHN::Access::system_has_virtualization_entitlement_acl_test\n  Sniglets::Navi::Node /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi/Node.pm 185 PXT::ACL::eval_acl\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi.pm 202 Sniglets::Navi::Node::visible\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi.pm 168 Sniglets::Navi::render_nav\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Navi.pm 128 Sniglets::Navi::format_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.8.8/PXT/Parser.pm 152 Sniglets::Navi::navi_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.8.8/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 632 PXT::Parser::expand_tags\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 124 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 124 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Mon Mar 09 18:14:55 2009] [error] Traceback sent to whayutin@redhat.com at /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm line 729.
Comment 1 Justin Sherrill 2009-03-12 14:09:23 EDT
can't reproduce this it seems
Comment 2 wes hayutin 2009-03-23 15:07:47 EDT
working in latest build
Satellite-5.3.0-RHEL5-re20090317.0-i386-embedded-oracle.iso
Comment 3 Michael Mráka 2009-08-07 05:28:01 EDT
Verified in stage -> RELEASE_PENDING.

* registered client w/ provisioning
* created snapshot tag
* no ISE
* installed one new package
* snapshot->packages shows the difference
Comment 4 Brandon Perkins 2009-09-10 15:58:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.