Bug 489422 - No network after last NM update
No network after last NM update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 18:40 EDT by Muayyad Alsadi
Modified: 2009-04-01 10:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.7.0.99-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-10 06:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
some diagnostics like portions of /var/log/messages (63.13 KB, text/plain)
2009-03-09 18:40 EDT, Muayyad Alsadi
no flags Details

  None (edit)
Description Muayyad Alsadi 2009-03-09 18:40:12 EDT
Created attachment 334582 [details]
some diagnostics like portions of /var/log/messages

Description of problem:
after restarting my F10 PC
network manager tray icon indicates no network

my other f10 pc on same network and conf have no problem
I checked the cables, replaced them
restarted my PC..etc.

the network back to work if I disabled networkman

Version-Release number of selected component (if applicable):
1:NetworkManager-0.7.0.99-1.fc10.i386

How reproducible:
always
 
Actual results:
no network

Expected results:
network

Additional info:
although I was able to start my net by hand
typical users won't receive more updates
so I marked it as urgent
please take back those updates ASAP

feel free to lower severity
I attached some diagnostics
Comment 1 Muayyad Alsadi 2009-03-09 19:11:01 EDT
after reverting to NetworkManager-0.7.0-1.git20090102.fc10.i386 things are normal now
Comment 2 Luke Macken 2009-03-09 20:05:57 EDT
I'm hitting what looks like this problem on 2 fresh F10 installs, with the latest stable updates...

NetworkManager-0.7.0.99-1.fc10.x86_64

#============= NetworkManager_t ==============
allow NetworkManager_t udev_exec_t:file { read execute execute_no_trans };

type=AVC msg=audit(1236620413.229:5): avc:  denied  { execute } for  pid=2188 co
mm="NetworkManager" name="udevadm" dev=dm-1 ino=26268 scontext=system_u:system_r
:NetworkManager_t:s0 tcontext=system_u:object_r:udev_exec_t:s0 tclass=file
Comment 3 Luke Macken 2009-03-09 20:07:47 EDT
Also note that doing a `service network restart` does not work either... I have to run `dhclient eth0` by hand to get back online.
Comment 4 Dan Williams 2009-03-09 23:29:02 EDT
'service network restart' doesn't work because the network service wants 'BOOTPROTO=dhcp' before it'll do DHCP on the interface.
Comment 5 Fedora Update System 2009-03-10 06:49:35 EDT
NetworkManager-0.7.0.99-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-03-10 06:49:56 EDT
NetworkManager-0.7.0.99-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Daniel Walsh 2009-03-10 09:12:08 EDT
Dan is NetworkManager execing udevadm now?
Comment 8 Dan Williams 2009-03-11 11:38:41 EDT
(In reply to comment #7)
> Dan is NetworkManager execing udevadm now?  

Yeah, only on F9 to get modem capabilities when you have a 3G card.
Comment 9 Muayyad Alsadi 2009-03-11 12:40:43 EDT
FYI: the update 1:NetworkManager-0.7.0.99-3.fc10.i386 did not solve "my" problem

should this bug be re-opened
Comment 10 Dan Williams 2009-03-11 12:46:33 EDT
(In reply to comment #9)
> FYI: the update 1:NetworkManager-0.7.0.99-3.fc10.i386 did not solve "my"
> problem
> 
> should this bug be re-opened  

Do you have "ONBOOT=no" in your /etc/sysconfig/network-scripts/ifcfg-eth0 file?
Comment 11 Muayyad Alsadi 2009-03-11 12:51:59 EDT
yes

cat /etc/sysconfig/network-scripts/ifcfg-eth0
# nVidia Corporation MCP73 Ethernet
DEVICE=eth0
HWADDR=00:1e:90:60:96:dc
ONBOOT=no

but now I have reverted to NetworkManager-0.7.0-1.git20090102.fc10.i386 (I don't think it affects the file because the file is now owned by NM)

if you want me to test anything I can reinstall any version NM and test
Comment 12 Muayyad Alsadi 2009-04-01 10:38:52 EDT
it works now

rpm -q NetworkManager
NetworkManager-0.7.0.99-5.git20090326.fc10.i386

I was notified about 
NetworkManager-0.7.0.99-3.fc10 has been pushed to the Fedora 10 stable

but not about the working one?!

Note You need to log in before you can comment on or make changes to this bug.