Bug 489461 - [RFE] Suggest possible duplicates while filing new bugs
[RFE] Suggest possible duplicates while filing new bugs
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 04:54 EDT by David Kovalsky
Modified: 2014-10-12 18:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 19:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KDE BZ screenshot (226.67 KB, image/png)
2009-03-11 13:02 EDT, David Kovalsky
no flags Details

  None (edit)
Description David Kovalsky 2009-03-10 04:54:59 EDT
There's a nice feature in Mozilla BZ and Gnome BZ which suggests possible duplicates during the process of filing a new bug. 

Guessing from the fact that I can't find it in upstream documentation, I guess this is an enhancement from their side. It's a nice feature that's IMO worth adapting and getting upstream. This would save our Bug Triagers some time in searching for duplicates. 

Some thoughts: 
 - having suggested duplicates can create a false feeling that the reported bug is not a duplicate. A clear message saying that with links to some searches would be nice.
Comment 1 David Kovalsky 2009-03-10 05:01:15 EDT
KDE BZ has the feature too
Comment 2 David Lawrence 2009-03-11 12:20:47 EDT
We have links already on the enter_bug.cgi page both advanced and guided. On the advanced page there is a link at the top to the "most frequently reported bugs" page which allows you to filter by product. Also the guided entry page has the duplicated page displayed in a frame. Also I have added in our SVN repo the link to the "most frequently reported bugs" from the home page as well just to make it easier to find. Is there any other areas that you feel we should link to it from? Is there some special report that mozilla.org is using that we do not have access to?

Dave
Comment 3 David Kovalsky 2009-03-11 12:55:30 EDT
Dave, 

though these improvements are great, I was thinking of something a bit different.

I'd love to see a 'search for duplicates' button right next to the 'commit' button on the enter_bug.cgi page. This would bring up search, possibly in another window, with bugs which match words from from the summary (I bet there are better searches, this just as an example). This would require user to use the button.

As an example from the KDE bugzilla, if you report a bug through the guided version, one of the steps is that it suggests a list of similar bugs you should check if what you're reporting is not a dupe (see screenshot). 

In our BZ, if a user files a bug, and the matching algorithm would suggest that there's a good matchk the user could be redirected to a page showing already reported bugs before his/her bug would be filed.
I know this is a lot of work, that's why I suggested to take a loot at how others do it if we could use it :)
Comment 4 David Kovalsky 2009-03-11 13:02:58 EDT
Created attachment 334836 [details]
KDE BZ screenshot
Comment 5 David Lawrence 2010-01-15 12:33:35 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 6 David Kovalsky 2010-01-18 09:43:55 EST
Still valid with 3.4
Comment 7 David Lawrence 2010-08-25 17:42:05 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 8 Matěj Cepl 2010-08-26 06:24:22 EDT
The bug is still doing just fine, thank you. There doesn't seem to be any worries about its elimination.
Comment 9 David Lawrence 2010-08-26 11:42:50 EDT
FWIW, in upstream 4.0 that we will eventually move to, the enter_bug.cgi page has a table that is displayed when a user starts typing something in the summary field that shows any possible duplicates. Maybe this will be useful for this request.

To see the feature in action go to: 
https://landfill.bugzilla.org/bugzilla-4.0-branch/enter_bug.cgi
Create an account, go to any product and start typing in the summary field.

Dave
Comment 10 Simon Green 2012-06-19 19:31:19 EDT
This was implement as part of the upstream changes when we release Bugzilla 4.2

  -- simon

Note You need to log in before you can comment on or make changes to this bug.