Bug 489518 - installer aborts while scanning for storage when disk w/mac partition table is connected
installer aborts while scanning for storage when disk w/mac partition table i...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pyparted (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 11:15 EDT by Jarod Wilson
Modified: 2009-06-17 16:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 16:24:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2009-03-10 11:15:33 EDT
Anaconda bails out almost immediately after it starts scanning for storage devices if a firewire disk is connected, dumping you back to vt1, where you see:

Running anaconda 11.5.0.25, the Fedora system installer - please wait...
14:44:29 Starting graphical installation...
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['udevadm', 'trigger', '--subsystem-match=block']
Running... ['udevadm', 'settle', '--timeout=2']
python: Objects/stringobject.c:115: PyString_FromString: Assertion 'str != ((void *)0)' failed.
install exited abnormally [1/1]
disabling swap...
unmounting filesystems...
etc.
Comment 1 Chris Lumens 2009-03-12 13:49:10 EDT
Python makes it really hard to tell which module is failing, but I'm going to go out on a limb here and say it's a problem in pyparted.  At the least, we do call PyString_FromString in a bunch of places without checking for NULL first.  I've fixed that up.  Please try the next rawhide which should have a new pyparted build and see if you no longer see this bug.  If it continues to show up, we'll have to figure out which module is causing the problem.
Comment 2 Jarod Wilson 2009-03-18 09:29:39 EDT
Looks like you got it, I'm looking at the partitioning screen now, complete with the firewire drive.
Comment 3 Jarod Wilson 2009-03-24 17:07:00 EDT
I just hit this one again. The FireWire drive was irrelevant. The mac partition table on the drive I originally hit this with seems to be the key -- an internal drive w/a mac partition table just triggered the same thing.
Comment 4 Chris Lumens 2009-03-25 11:46:32 EDT
This could be the string handling in the pyparted libparted exception code.
Comment 5 Hans de Goede 2009-03-26 08:24:32 EDT
(In reply to comment #4)
> This could be the string handling in the pyparted libparted exception code.  

Ack, I believe the abort will be fixed by the patch I've just attached to:
https://fedorahosted.org/pyparted/ticket/3

Then we will probably still get a backtrace, but getting rid of the abort is the
first step in fixing this.
Comment 6 Chris Lumens 2009-03-27 11:48:23 EDT
I just merged this patch in, so this bug should be better in the next build of pyparted.  Of course we will still have the backtrace to contend with, but that should be easy.
Comment 7 Bug Zapper 2009-06-09 08:05:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jarod Wilson 2009-06-17 16:24:27 EDT
Finally got around to checking on this one. The abort is gone, but I still run into bug 498602. Will continue the discussion there, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.