Bug 489523 - ibus oddities with F11 alpha
ibus oddities with F11 alpha
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 11:37 EDT by Jason Merrill
Modified: 2009-09-06 03:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Merrill 2009-03-10 11:37:48 EDT
Description of problem:

When I logged on to the F11 alpha live CD, there was a floating tab on my desktop which seemed to be for selecting the iBus engine.

yum update ibus made it go away, but I got an error "GLib version too old (micro mismatch)"; apparently 2.19.5 isn't enough for ibus-gtk.  Updating glib2 to 2.19.10 seemed to fix that issue.

But now the input method chooser seems to be confused; enabling the input method feature with Preferences/Personal/Input Method doesn't stick, if I open the dialog again the checkbox is still off.  Updating im-chooser didn't affect this issue; the applet in the notification error pops up an error about "mismatch the version of im-settings-daemon, no detailed information"

I haven't updated the whole system, as I don't think I have enough room on the USB stick and yum is failing to update glibc at the moment.  And I don't really care about iBus, just wanted that floater to go away.  Feel free to close this bug if it doesn't have any useful information for you.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jens Petersen 2009-03-10 20:28:42 EDT
(In reply to comment #0)
> When I logged on to the F11 alpha live CD, there was a floating tab on my
> desktop which seemed to be for selecting the iBus engine.

Which language are you using?  For non-Asian languages, ibus should not appear normally by default.

> yum update ibus made it go away, but I got an error "GLib version too old
> (micro mismatch)"; apparently 2.19.5 isn't enough for ibus-gtk.  Updating glib2
> to 2.19.10 seemed to fix that issue.

This is fixed in rawhide (should be in F11Beta).

> But now the input method chooser seems to be confused; enabling the input
> method feature with Preferences/Personal/Input Method doesn't stick, if I open
> the dialog again the checkbox is still off.  Updating im-chooser didn't affect
> this issue; the applet in the notification error pops up an error about
> "mismatch the version of im-settings-daemon, no detailed information"

That sounds like an imsettings: may have been fixed since, Tagoh-san?  

> I haven't updated the whole system, as I don't think I have enough room on the
> USB stick and yum is failing to update glibc at the moment.  And I don't really
> care about iBus, just wanted that floater to go away.

Thanks for your report.
Comment 2 Akira TAGOH 2009-03-10 22:12:20 EDT
(In reply to comment #1)
> > But now the input method chooser seems to be confused; enabling the input
> > method feature with Preferences/Personal/Input Method doesn't stick, if I open
> > the dialog again the checkbox is still off.  Updating im-chooser didn't affect
> > this issue; the applet in the notification error pops up an error about
> > "mismatch the version of im-settings-daemon, no detailed information"
> 
> That sounds like an imsettings: may have been fixed since, Tagoh-san?  

When any API/ABI changes happened, soname is bumped. so it's highly unlikely to ship the different API version of imsettings and im-chooser. so possible idea is old process just keeps running. kill it or restart your desktop and try again.
Comment 3 Jason Merrill 2009-03-11 01:32:25 EDT
I'm using English, with Dvorak keyboard layout.

Rebooting does seem to have fixed the im-chooser problem.
Comment 4 Jens Petersen 2009-03-11 01:56:24 EDT
(In reply to comment #3)
> I'm using English, with Dvorak keyboard layout.
> 
> Rebooting does seem to have fixed the im-chooser problem.  

Is your installation up to date with rawhide?  Alpha is a bit old now.
If you can try again with Beta (soon) that would be helpful, thanks.
Comment 5 Bug Zapper 2009-06-09 08:05:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Jason Merrill 2009-06-14 15:17:24 EDT
This all worked fine in the 0331 testday LiveCD.

Note You need to log in before you can comment on or make changes to this bug.