Bug 489528 - Strange assignment in linux-g++/qmake.conf
Strange assignment in linux-g++/qmake.conf
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 11:57 EDT by Ivan Efremov
Modified: 2009-03-12 11:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 10:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Efremov 2009-03-10 11:57:09 EDT
Description of problem:

linux-g++/qmake.conf contains the following line:

QMAKE_CFLAGS_RELEASE	+= -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2  -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables

The question is: Why does CFLAGS_RELEASE variable contains '-g' debugging flag? Right after '-O2'? There shouldnt be any debuginfo when building in release mode.

Version-Release number of selected component (if applicable): 4.4.3
Comment 1 Rex Dieter 2009-03-10 13:55:16 EDT
These are the default compiler flags by which all of fedora is compiled with.
Comment 2 Rex Dieter 2009-03-10 13:59:15 EDT
well, I'll discuss it with my fellow qt/kde maintainers, maybe we could consider kicking out -g (but that would likely have ill side-effects building other qt-related packages in fedora... which we may or may not be willing to deal with).
Comment 3 Kevin Kofler 2009-03-10 15:04:39 EDT
We build our release binaries with debugging information in Fedora and then have RPM split it into separate files which land in separate -debuginfo packages.
Comment 4 Ivan Efremov 2009-03-11 02:41:28 EDT
OK, I understand, but it really looks like a some kind of hack, because other major linux distributions (AFAIK, including fedora 9) don't use such _global_ assignments.
Comment 5 Ivan Efremov 2009-03-11 02:45:53 EDT
In fact it really affects applications which have qmake-based build system. It looks very strange when you build application (and create binary packages) in a _standard_ way on number of linuxes, and resulting _release_ binaries on fedora 10 are ten times bigger than others because of debug information.
Comment 6 Ngo Than 2009-03-12 10:09:10 EDT
It's the default compiler flag in fedora what is needed to get the debug infos. The user still can strip the binary with install -s that is supported in Makefiles by install, if they don't want the debug information.
Comment 7 Ivan Efremov 2009-03-12 10:21:23 EDT
Yes sure, but installation instructions in makefiles are also generated by qmake. And when I use everything by default it doesn't include strip to Makefile. It's specific problem only of fedora 10.
Comment 8 Kevin Kofler 2009-03-12 11:10:36 EDT
We also configure qmake not to strip by default for the same reason we have it use -g by default.

Note You need to log in before you can comment on or make changes to this bug.