Bug 489563 - MAX_LOCKDEP_ENTRIES too low
MAX_LOCKDEP_ENTRIES too low
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 13:49 EDT by Mace Moneta
Modified: 2013-04-08 06:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 01:22:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2009-03-10 13:49:04 EDT
Description of problem:

Mar 10 13:40:20 slayer kernel:BUG: MAX_LOCKDEP_ENTRIES too low!
Mar 10 13:40:20 slayer kernel:turning off the locking correctness validator.

Version-Release number of selected component (if applicable):

kernel-2.6.29-0.215.rc7.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1.Boot
2.
3.
  
Actual results:

Lock dependency validator: Copyright (c) 2006 Red Hat, Inc., Ingo Molnar
... MAX_LOCKDEP_SUBCLASSES:  8
... MAX_LOCK_DEPTH:          48
... MAX_LOCKDEP_KEYS:        8191
... CLASSHASH_SIZE:          4096
... MAX_LOCKDEP_ENTRIES:     8192
... MAX_LOCKDEP_CHAINS:      16384
... CHAINHASH_SIZE:          8192
 memory used by lock dependency info: 4351 kB
 per task-struct memory footprint: 2688 bytes

BUG: MAX_LOCKDEP_ENTRIES too low!
turning off the locking correctness validator.

Expected results:


Additional info:
Comment 1 Kyle McMartin 2009-03-16 23:50:16 EDT
Ick.

I'm unhappy with how much memory this is using statically... I've increased it to 10240, let's see if that will be sufficient.
Comment 2 Jonathan Kamens 2009-03-20 15:50:39 EDT
Just got this with  2.6.29-0.258.rc8.git2.fc11.i686.PAE :

BUG: MAX_LOCKDEP_CHAINS too low!
turning off the locking correctness validator.
Comment 3 Mace Moneta 2009-03-22 21:11:34 EDT
Running 2.6.29-0.267.rc8.git4.fc11.x86_64:

Mar 22 17:22:58 slayer kernel:Lock dependency validator: Copyright (c) 2006 Red Hat, Inc., Ingo Molnar
Mar 22 17:22:58 slayer kernel:... MAX_LOCKDEP_SUBCLASSES:  8
Mar 22 17:22:58 slayer kernel:... MAX_LOCK_DEPTH:          48
Mar 22 17:22:58 slayer kernel:... MAX_LOCKDEP_KEYS:        8191
Mar 22 17:22:58 slayer kernel:... CLASSHASH_SIZE:          4096
Mar 22 17:22:58 slayer kernel:... MAX_LOCKDEP_ENTRIES:     10240
Mar 22 17:22:58 slayer kernel:... MAX_LOCKDEP_CHAINS:      16384
Mar 22 17:22:58 slayer kernel:... CHAINHASH_SIZE:          8192
Mar 22 17:22:58 slayer kernel: memory used by lock dependency info: 4463 kB
Mar 22 17:22:58 slayer kernel: per task-struct memory footprint: 2688 bytes
Mar 22 17:22:58 slayer kernel:allocated 82575360 bytes of page_cgroup
Mar 22 17:22:58 slayer kernel:please try cgroup_disable=memory option if you don't want

Like comment #2, I now get:

Mar 22 21:04:23 slayer kernel:BUG: MAX_LOCKDEP_CHAINS too low!
Mar 22 21:04:23 slayer kernel:turning off the locking correctness validator.
Comment 4 Kyle McMartin 2009-03-23 10:27:25 EDT
Yeah, ugh. The problem is it's a static allocation... There's really no nice way of dealing with this. (Presumably the goal here is to not take any locks in the lockdep allocation path. ;-)

I'll bump it by another 2048, and if that's insufficient, I may just turn it off if it's going to be turning itself off anyway.
Comment 5 Jeff Kuehn 2009-03-31 22:16:20 EDT
Just FYI: I'm seeing this on the Fedora 11 Beta Live CD at boot.
Comment 6 Chuck Ebbert 2009-06-09 01:27:29 EDT
Still happening? The limit was raised again recently.
Comment 7 Mace Moneta 2009-06-09 01:35:57 EDT
I'm not seeing it anymore, but I'm not seeing the "Lock dependency validator" load either.

kernel-2.6.29.4-167.fc11.x86_64
Comment 8 Bug Zapper 2009-06-09 08:05:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Dave Jones 2009-06-15 11:10:47 EDT
The F11 kernel doesn't have lockdep enabled by default (unless you run the kernel-debug flavor).  Rawhide kernels have it always enabled in all builds.
Comment 10 Mace Moneta 2009-11-30 01:22:41 EST
I haven't seen this in a long while, even with rawhide kernels.  Closing.
Comment 11 Mikko Tiihonen 2013-04-08 06:10:31 EDT
I got this now:

[    0.000000] Linux version 3.9.0-0.rc5.git3.1.fc20.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 4.8.0 20130320 (Red Hat 4.8.0-0.18) (GCC) ) #1 SMP Thu Apr 4 17:31:14 UTC 2013

[    0.000000] Lock dependency validator: Copyright (c) 2006 Red Hat, Inc., Ingo Molnar
[    0.000000] ... MAX_LOCKDEP_SUBCLASSES:  8
[    0.000000] ... MAX_LOCK_DEPTH:          48
[    0.000000] ... MAX_LOCKDEP_KEYS:        8191
[    0.000000] ... CLASSHASH_SIZE:          4096
[    0.000000] ... MAX_LOCKDEP_ENTRIES:     16384
[    0.000000] ... MAX_LOCKDEP_CHAINS:      32768
[    0.000000] ... CHAINHASH_SIZE:          16384
[    0.000000]  memory used by lock dependency info: 6367 kB
[    0.000000]  per task-struct memory footprint: 2688 bytes

[15921.215921] BUG: MAX_LOCKDEP_ENTRIES too low!

Note You need to log in before you can comment on or make changes to this bug.