Bug 489611 - New libgxim breaks Qt4 applications
New libgxim breaks Qt4 applications
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
: 465505 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 18:05 EDT by Mark Summerfield
Modified: 2009-03-27 10:53 EDT (History)
17 users (show)

See Also:
Fixed In Version: 0.105.1-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 488223
Environment:
Last Closed: 2009-03-27 10:53:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
.xsession-errors (25.46 KB, application/octet-stream)
2009-03-11 06:59 EDT, Mark Summerfield
no flags Details

  None (edit)
Description Mark Summerfield 2009-03-10 18:05:37 EDT
+++ This bug was initially created as a clone of Bug #488223 +++

After today's updates keyboard input is once again broken in Qt4 applications. I now have intermittent keyboard errors---either no response or wrong keys processed---in both my own applications and supplied ones, e.g., KMail. 

The errors are such that I am pretty well unable to work with Fedora (since I use KMail all day and write and test Qt4 apps all the time). Please could you include a test for Qt4 apps when you next "fix" libgxim (or whatever is causing the bug)?

I originally reported this in 488411.
Comment 1 Akira TAGOH 2009-03-11 06:32:22 EDT
Sorry for bothering you but the above information doesn't help me to resolve your issue.
Please give me more info:

1. what desktop are you using?
2. what's a reproducibility? can you still see that after restarting the desktop?
3. when does it happen?
4. Can you see any warnings or errors in .xsession-errors? if you can provide a whole logs, would be better.

KMail works for me on both of GNOME and KDE. there should be any triggers to see your issue.
Comment 2 Mark Summerfield 2009-03-11 06:59:28 EDT
Created attachment 334779 [details]
.xsession-errors

1. I was using GNOME. Due to the problems I've now switched to KDE.
2. I rebooted several times. To take KMail as one example. It worked fine for several hours of intermittent use. Then at some point, having sent messages in the previous hours I would do Ctrl+N (new message) as usual, and although the new message dialog appeared all keyboard interaction with KMail stopped. Another example is a PIM application that I wrote in PyQt4. I used it to keep notes and again, it would work fine for some time, then suddenly editing text would stop working and the application would stop responding to the keyboard---this application has been in use for several years with no problems of this kind before.
3. Randomly unfortunately!
4. I've attached .xession-errors, but it might not have the GNOME stuff in it since I have now switched to KDE. (Too early to say if KDE has the same bug though.)
Comment 3 Rex Dieter 2009-03-11 08:57:30 EDT
And a few details please:
rpm -q libgxim qt kdelibs
Comment 4 Akira TAGOH 2009-03-11 09:14:12 EDT
Doesn't it happen on KDE right? imsettings features are totally disabled on KDE and no involvements to libgxim at all. if you say it also happens on even KDE, please give me what "echo $XMODIFIERS" say.

I guess it might be a same issue to Bug #488976?
Comment 5 Mark Summerfield 2009-03-11 09:23:44 EDT
$ rpm -q libgxim qt kdelib
libgxim-0.3.2-4.fc10.i386
qt-4.4.3-10.fc10.i386
package kdelib is not installed

(Of course it might have been different yesterday since I did a complete KDE install today---however, I don't think libgxim or qt were changed.)

I haven't experienced the problem with KDE---so far---but because the problem is inconsistent it might happen later on; but I'd assume for now that KDE is okay.
Comment 6 Akira TAGOH 2009-03-11 09:41:24 EDT
Okay. I'm suspecting your problem would be same to Bug #488976. so can you follow up on https://bugzilla.redhat.com/show_bug.cgi?id=488976#c7 on GNOME and see if your problem is gone with it?
Comment 7 Mark Summerfield 2009-03-11 12:31:25 EDT
OK, I've installed the two packages and switched on the sync_on_forward. I won't really get the chance to see how it works 'til tomorrow though.
Comment 8 Akira TAGOH 2009-03-12 07:38:12 EDT
Sorry for trouble. better installing http://koji.fedoraproject.org/koji/taskinfo?taskID=1236736.
and that would be really appreciated if you can test both cases of turning sync_on_forward on and off.
Comment 9 Mark Summerfield 2009-03-12 07:50:10 EDT
Hi, yesterday I installed:
imsettings-0.105.1-3.fc10.3.i386.rpm
imsettings-libs-0.105.1-3.fc10.3.i386.rpm
which seem to be the same ones as you just mentioned.
I set sync_on_forward true yesterday and have not had any problems this morning.
I've now done sync_on_forward false and will let you know if I hit any problems.
Comment 10 Domingo Becker 2009-03-12 08:56:46 EDT
(In reply to comment #0)
> 
> After today's updates keyboard input is once again broken in Qt4 applications.
> I now have intermittent keyboard errors---either no response or wrong keys
> processed---in both my own applications and supplied ones, e.g., KMail. 
> 

I can confirm this behaviour for applications under wine on a laptop, fedora 10, GNOME, desktop effects enabled.
I found that if I enable input method (System->Preferences->Personal->Input Method) it works fine.
If I find problems I will report in this bug.

regards
Comment 11 Akira TAGOH 2009-03-12 09:05:09 EDT
confused. confirm with which version of libgxim and imsettings?
Comment 12 Domingo Becker 2009-03-12 09:17:20 EDT
$ rpm -q libgxim imsettings
libgxim-0.3.2-4.fc10.i386
imsettings-0.105.1-2.fc10.i386
Comment 13 Akira TAGOH 2009-03-12 09:28:47 EDT
Thanks. see Comment #6 and Comment #8 for pre-testing package.
Comment 14 Mark Summerfield 2009-03-12 13:27:37 EDT
After one day of use (half with sync_on_forward false, half with it true) I've found no difference, and none of the problems I had before has recurrred.

When you add the fixed packages will I have to do anything special, or will they just work when I do "yum update"?

Thanks.
Comment 15 Akira TAGOH 2009-03-12 20:21:20 EDT
No, basically you don't need to do anything else unless you find any issues on either of mode.
Comment 16 Akira TAGOH 2009-03-17 00:53:27 EDT
*** Bug 465505 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2009-03-17 02:55:37 EDT
imsettings-0.105.1-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/imsettings-0.105.1-4.fc10
Comment 18 Fedora Update System 2009-03-18 15:14:14 EDT
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update imsettings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2843
Comment 19 Fedora Update System 2009-03-27 10:53:19 EDT
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.