Bug 48963 - Unable to handle kernel paging request
Unable to handle kernel paging request
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-12 13:59 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 23:49:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-12 13:59:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; WAN00)

Description of problem:
Kernel dumps CPU state on CRT with message:
Unable to handle kernel paging request at virthal address xxxxxx


How reproducible:
Always

Steps to Reproduce:
1. Start RH 6.1
2. Wait several hours.
3.
	

Actual Results:  Symptoms:
 After running for several hours (random 1 hour up to 2 days) I get the 
following dump on the screen (this occurs most times while doing no work, 
just idling). The dumps get more frequent until the computer finally locks 
up:

Unable to handle kernel paging request at virtual address 41c1b880
current->tss.cr3 = 04948000, %cr3 = 04948000
*pde = 00000000
Oops: 0002
CPU: 0
EIP: 0010:[<c0130b61>]
EFLAGS: 00010206
eax: c1d598c0 ebx: c1c1b760 ecx: c1cb780 edx: 41c1b880
esi: 00000000 edi: 080aa338 ebp: bffffa40 esp: c2609f9c
ds: 0018 es: 0018 ss: 0018
Process bash (pid: 7156, process nr: 64, stackpage=c2609000)
<stackdump goes here>
<call trace>
Code: 89 02 8d 43 18 39 43 18 0f 85 95 00 00 00 8b 43 28 8b 53 2c
------
That's it! 
I get this paging problem only in 6.1. I tried upgrading to the latest 6.1 
kernel, and it does this even more often.
7.1 kernel will not deal with the Adaptec, 7.0 and 6.2 crash on loading 
with scsi errors.
This hardware runs win98/winNT just fine, no glitches at all.


Expected Results:  Should run flawlessly under 6.1, 6.2 7.0 or 7.1

Additional info:

Hardware info:
Intel LX chipset on motherboard (P2BLX)
Intel 333 mhz Celeron cpu, 256mb ram
Adaptec 2940U scsi card with 3 IBM 9.1 gb drives (narrow scsi buss)
Toshiba scsi CD drive, HP scsi tape drive
RH6.1 installed on drive 0. /boot 23mb, /swap 256mb, / 8.1gb
Comment 1 Arjan van de Ven 2001-07-12 14:03:07 EDT
I assume the errata'd kernel is 2.2.19, could you check this ?

You can most likely install 7.1 by passing it the "noapic" option to work
around some motherboard/biosbugs.

Comment 2 Need Real Name 2001-07-12 23:49:21 EDT
Kernel version is 2.2.12-20
Comment 3 Need Real Name 2001-07-15 17:21:00 EDT
Sorry, guys. This turned out to be a hardware problem.
After extensive testing, I have found that the problem is related to a 
defective Programmabe Interrupt Controller on the motherboard, when the board 
warms up over a certain temperature, it begins to mess up interrupt routing. I 
have replaced the board and all is well with version 6.1 now.
Cannot load 7.1 no matter what options I pass to the kernel. Those problems are 
better described in other existing bug reports.
Thanks,
Del

Note You need to log in before you can comment on or make changes to this bug.