Bug 489660 - Bind exited with assertion related to result variable
Bind exited with assertion related to result variable
Status: CLOSED DUPLICATE of bug 475202
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.7
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Adam Tkac
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 05:31 EDT by masevac
Modified: 2013-04-30 19:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 06:27:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masevac 2009-03-11 05:31:41 EDT
Hi, 
  I have 8 servers with named which are synchronized using rndc.
  Yesterday, 4 of the 8 server exited at the same time.
  After looking in logs, the only relevant lines I found is
---BEGIN---
Mar 10 13:01:03 server named[3334]: view.c:1116: INSIST(result == 0 || result == 23) failed
Mar 10 13:01:03 server named[3334]: exiting (due to assertion failure)
---END---

  In those server I have two different versions of CentOS (4.7 and 5.2) and so, different versions of named. Anyway 3 servers 4.7 and 1 server 5.2 stopped. The remaining server had not any problem. The also have CentOS versions 4.7 and 5.2, and the same named versions 9.2.4 and 9.3.4-P1
   

Version-Release number of selected component (if applicable):
9.2.4
9.3.4-P1

As far as I know the problem it's not reproducible

  
Actual results:
The named server exited

Expected results:
The named server will continue to run

Additional info:
I checked all named log lines, and there are not any more line relevant in the moment of the "sinchronized" exit. All warnings/errors are usual in log file, they are not only at moment of the exit.
Comment 1 masevac 2009-03-11 05:36:16 EDT
Created bug https://bugzilla.redhat.com/show_bug.cgi?id=489662 for version 5.2
Comment 2 Adam Tkac 2009-03-11 06:27:16 EDT

*** This bug has been marked as a duplicate of bug 475202 ***

Note You need to log in before you can comment on or make changes to this bug.