Bug 489667 - Too much dependencies to install.
Too much dependencies to install.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 06:00 EDT by alex
Modified: 2009-05-08 13:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 13:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alex 2009-03-11 06:00:21 EDT
Description of problem:

$ sudo yum install gstreamer-plugins-good
...
Dependencies Resolved

======================================================================================================
 Package                                Arch        Version                        Repository    Size
======================================================================================================
Installing:
 gstreamer-plugins-good                 x86_64      0.10.14-2.fc11                 rawhide      1.1 M
Installing for dependencies:
 PolicyKit-kde                          x86_64      4.2.0-3.fc11                   rawhide      109 k
 avahi-glib                             x86_64      0.6.24-2.fc11                  rawhide       18 k
 clucene-core                           x86_64      0.9.21-2.fc11                  rawhide      347 k
 enchant                                x86_64      1:1.4.2-5.fc11                 rawhide       52 k
 exiv2-libs                             x86_64      0.18-2.fc11                    rawhide      840 k
 fedora-gnome-theme                     noarch      8.0.0-8.fc11                   rawhide       11 k
 fedora-icon-theme                      noarch      1.0.0-5.fc11                   rawhide      117 k
 gnome-icon-theme                       noarch      2.25.91-2.fc11                 rawhide      3.9 M
 gnome-keyring                          x86_64      2.25.92-1.fc11                 rawhide      1.2 M
 gnome-mime-data                        noarch      2.18.0-4.fc11                  rawhide      713 k
 gnome-mount                            x86_64      0.8-5.fc11                     rawhide      150 k
 gnome-themes                           noarch      2.25.92-1.fc11                 rawhide      1.5 M
 gnome-vfs2                             x86_64      2.24.0-5.fc11                  rawhide      945 k
 gtk-nodoka-engine                      x86_64      0.7.2-3.fc11                   rawhide       54 k
 hunspell                               x86_64      1.2.8-4.fc11                   rawhide      203 k
 hunspell-en                            noarch      0.20090216-2.fc11              rawhide      625 k
 kde-filesystem                         noarch      4-24.fc11                      rawhide       21 k
 kde-settings                           noarch      4.2-4.20090225svn.fc11         rawhide       35 k
 kdelibs                                x86_64      6:4.2.1-4.fc11                 rawhide       14 M
 kdelibs-common                         x86_64      6:4.2.1-4.fc11                 rawhide      363 k
 libXres                                x86_64      1.0.3-6.fc11                   rawhide       14 k
 libasyncns                             x86_64      0.7-2.fc11                     rawhide       25 k
 libavc1394                             x86_64      0.5.3-5.fc11                   rawhide       47 k
 libbonobo                              x86_64      2.24.0-4.fc11                  rawhide      507 k
 libdv                                  x86_64      1.0.0-7.fc11                   rawhide       83 k
 libgnome                               x86_64      2.24.1-9.fc11                  rawhide      700 k
 libiec61883                            x86_64      1.2.0-2.fc11                   rawhide       36 k
 libmodplug                             x86_64      1:0.8.4-4.fc11                 rawhide      171 k
 libmpcdec                              x86_64      1.2.6-5.fc11                   rawhide       27 k
 libnotify                              x86_64      0.4.5-2.fc11                   rawhide       36 k
 libproxy                               x86_64      0.2.3-9.fc11                   rawhide       37 k
 libproxy-bin                           x86_64      0.2.3-9.fc11                   rawhide      6.3 k
 libproxy-mozjs                         x86_64      0.2.3-9.fc11                   rawhide      9.1 k
 libproxy-python                        x86_64      0.2.3-9.fc11                   rawhide      6.1 k
 libsexy                                x86_64      0.1.11-10.fc11                 rawhide       45 k
 libshout                               x86_64      2.2.2-4.fc11                   rawhide       43 k
 libsoup                                x86_64      2.25.91-2.fc11                 rawhide      228 k
 libv4l                                 x86_64      0.5.8-2.fc11                   rawhide       75 k
 libwnck                                x86_64      2.25.91-2.fc11                 rawhide      383 k
 libxslt                                x86_64      1.1.24-4.fc11                  rawhide      537 k
 mozilla-filesystem                     x86_64      1.9-4.fc11                     rawhide      3.3 k
 mysql-libs                             x86_64      5.1.32-1.fc11                  rawhide      2.1 M
 nodoka-filesystem                      noarch      0.3.90-3.fc11                  rawhide      3.5 k
 nodoka-metacity-theme                  noarch      0.3.90-3.fc11                  rawhide      8.6 k
 notification-daemon                    x86_64      0.4.0-2.fc11                   rawhide       50 k
 notification-daemon-engine-nodoka      x86_64      0.1.0-6.fc11                   rawhide       28 k
 oxygen-icon-theme                      noarch      4.2.1-1.fc11                   rawhide       15 M
 phonon                                 x86_64      4.3.1-2.fc11                   rawhide      155 k
 phonon-backend-xine                    x86_64      4.3.1-2.fc11                   rawhide      169 k
 postgresql-libs                        x86_64      8.3.6-2.fc11                   rawhide      215 k
 pulseaudio-libs                        x86_64      0.9.15-3.test5.fc11            rawhide      341 k
 qt                                     x86_64      1:4.5.0-3.fc11                 rawhide      3.9 M
 qt-x11                                 x86_64      1:4.5.0-3.fc11                 rawhide       16 M
 raptor                                 x86_64      1.4.18-2.fc11                  rawhide      227 k
 rasqal                                 x86_64      0.9.15-4.fc11                  rawhide      193 k
 redland                                x86_64      1.0.7-6.fc11                   rawhide      218 k
 solar-backgrounds-common               noarch      0.92.0-2.fc11                  rawhide      5.2 M
 solar-kde-theme                        noarch      0.1.17-2.fc11                  rawhide      289 k
 soprano                                x86_64      2.2.3-1.fc11                   rawhide      689 k
 startup-notification                   x86_64      0.9-6.fc11                     rawhide       38 k
 strigi-libs                            x86_64      0.6.4-3.fc11                   rawhide      471 k
 taglib                                 x86_64      1.5-4.fc11                     rawhide      178 k
 xdg-user-dirs                          x86_64      0.10-4.fc11                    rawhide       41 k
 xine-lib                               x86_64      1.1.16.2-4.fc11                rawhide      2.4 M
 xulrunner                              x86_64      1.9.1-0.9.beta2.fc11           rawhide      9.7 M

Transaction Summary
======================================================================================================
Install     66 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 86 M
Is this ok [y/N]:

Version-Release number of selected component (if applicable):


How reproducible:
Try to install it with yum
  
Actual results:
It takes with it gnome/kde and so on crazy deps. 

Expected results:
Install only really needed packages for work. 

Additional info:
Comment 1 Rex Dieter 2009-03-11 08:59:52 EDT
One way to avoid PolicyKit-kde (and associated kde dependencies) is to pre-install PolicyKit-gnome, and try installing gstreamer-* again.
Comment 2 Adam Jackson 2009-03-11 15:15:27 EDT
Which features would you like removed from the gstreamer plugins to reduce their dependency list?
Comment 3 alex 2009-03-11 16:19:23 EDT
I don't very familiar with gstreamer. Let's assume, I use some light-weight window manager, I have no gnome/kde. Should I really install gnome/kde dependencies? Is where any way to avoid it?

By the way. It's no only my opinion, but packages in Fedora is going more and more complex way with increasing deps :-(

As second example (It's no about gstreamer), which I remember right now - 
rpm -qR gettext-devel | grep gcj
libgcj_bc.so.1()(64bit)
Comment 4 Rex Dieter 2009-03-11 16:29:59 EDT
see comment #1.

Some apps in fedora are starting to include
Requires: PolicyKit-authentication-agent
The item in this transaction triggering that was gnome-mount.

2 packages currently Provides: PolicyKit-authentication-agent
they are:
PolicyKit-gnome
PolicyKit-kde

If you don't have either currently installed, yum tries to pick one for you (to your benefit or dismay).
Comment 5 alex 2009-03-11 16:44:14 EDT
I try to make some analogy probably not the best. Let's make a little overview of dovecot package from fedora:

[root@fedora-dev /]# yum search dovecot | grep '^d' | cut -d: -f1
dovecot.i386 
dovecot-devel.i386 
dovecot-gssapi.i386 
dovecot-ldap.i386 
dovecot-managesieve.i386 
dovecot-mysql.i386 
dovecot-pgsql.i386 
dovecot-sieve.i386 
dovecot-sqlite.i386 

I don't have to install all these packages: mysql/pgsql/sqlite/ldap. If I need some of them, it would be installed as deps for appropriate dovecot-* package. Where is no way doing something like that in this case?
Comment 6 Rex Dieter 2009-03-11 17:00:26 EDT
I think we're talking past each other.  that's ok, I'll try to make it clearer.

You're mostly concerned about the kde-related dependencies getting pulled in?  Yes or no?

If so, 
yum install PolicyKit-gnome
yum install gstreamer-plugins-good
will get you what you want.


If you want each item in gstreamer-plugins-good that contains new/extra dependencies to be split into separate packaging, that's something altogether different.
Comment 7 Vitaly Mayatskikh 2009-03-11 17:07:49 EDT
I can agree with reporter. I'm using Fedora day to day starting from Core 2 and dependencies problem gets worse and worse. We have too much complex all-in-one packages. Nowadays its impossible to have simple Fedora installation without half of gnome, kde and java stuff. For example, Fedora 9 and 10 (I'm not sure about rawhide) requires tomcat server for OpenOffice due to weird dependency in some package, which does not relate to OO.org directly. It's madness to require tomcat for usual desktop installation!

Try to do `rpm -qa | less' and to see how many packages you don't really need. Ever need.

I think packages complexity reduction can be a major feature for next Fedora releases.
Comment 8 alex 2009-03-11 17:26:51 EDT
No only about kde. I have understood trick with yum, thank you. Should I install at least 'kde or gnome deps'? Can I avoid all of them? 

Thanks also to Vitaly Mayatskikh for his comment. Yeah, I want to see less complex system.
Comment 9 Rex Dieter 2009-03-11 18:32:50 EDT
Less complex?  Three's a tradeoff you know.

You're tradeing deps for more packages is all.  Instead of a single gstreamer-plugins-good, now you'll have umpteen gstreamer-plugin-foo* subpkgs.
Comment 10 Rex Dieter 2009-03-11 18:34:02 EDT
Vitaly, you're welcome to help implement the idea... otherwise, it's simply more work for the existing already overworked pkg maintainers.
Comment 11 alex 2009-03-11 18:49:13 EDT
My english not strong to understand meaning of 'Three's a tradeoff'. But I certainly understand whole point, what bug reports in "the best of" should contain some proposed patch. In the next time reporting I will try to make some appropriate spec(s) or so on. It's all about free time, yes.
Comment 12 Rex Dieter 2009-03-11 20:12:20 EDT
From what I gather, I'll mark this as a wishlist item requesting more extensive pkg splits (FutureFeature keyword), and leave it to the maintainer(s) in question to decide what to do with it.
Comment 13 Vitaly Mayatskikh 2009-03-12 02:23:49 EDT
As for me, I'd like to see tens of thousands of separate packages instead of one fedora-blob.rpm ;) And it will be my pleasure to help with solving of dependencies complexity problem. However, it will require not only splitting one big package to several of smaller size, but also introduce a new policy of packages installation, like it does, for example, in Debian. They have 3 possibilities of deps solving: "minimal", "base", "recommended" (I don't remember exactly). And the system installed with minimal deps is really minimal, only 200-300 megs on disk.

Thanks for understanding, Rex!
Comment 14 Adam Jackson 2009-05-08 13:57:23 EDT
We currently have no plans to split gstreamer-plugins-good apart.  The PolicyKit integration does require a PK auth agent, and yum happens to pick the KDE one for whatever reason, but that's not gstreamer's fault.

Note You need to log in before you can comment on or make changes to this bug.