Bug 489698 - squashfs zlib corruption
squashfs zlib corruption
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 489520 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker 490515
  Show dependency treegraph
 
Reported: 2009-03-11 10:00 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 490515 (view as bug list)
Environment:
Last Closed: 2009-03-12 11:14:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-logs.tgz (anaconda.log, syslog, vncserver.log, program.log etc...) (10.13 KB, application/octet-stream)
2009-03-11 10:00 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-11 10:00:42 EDT
Created attachment 334800 [details]
anaconda-logs.tgz (anaconda.log, syslog, vncserver.log, program.log etc...)

Description of problem:

Start a vnc install of rawhide on an IBM Power5 ppc system.  Once you connect to the vnc session (from another rawhide system) ... the display is all black.

Version-Release number of selected component (if applicable):

 * anaconda version 11.5.0.27 on ppc
 * tigervnc-0.0.90-0.3.20090303svn3631.fc11.i586

How reproducible:

 * Everytime

Steps to Reproduce:
 1. Boot rawhide vmlinuz+ramdisk.image.gz on a IBM Power5 system (ibm-505-lp1.test.redhat.com)
 2. Select VNC install (no passwd)
 3. Connect to the 
  
Actual results:

 * Launcing vncviewer from a rawhide client displays an empty black window

Expected results:

 * I expect to see the installer on the vncviewer window

Additional info:

 * using vncviewer from vnc-4.1.3-1.fc10 also has this problem, so I suspect it's not the client

 * On anaconda, /tmp/vncserver.log shows the following upon connection.

sh-4.0# tail -fn0 /tmp/vncserver.log 
Wed Mar 11 13:37:30 2009
 Connections: accepted: 10.11.228.34::48267
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type None(1)
 JpegEncoder: no hardware JPEG compressor available
 VNCSConnST:  Server default pixel format depth 16 (16bpp) big-endian rgb565
 VNCSConnST:  Client pixel format depth 24 (32bpp) little-endian rgb888

 * See attached anaconda-logs.tgz for all files in /tmp
Comment 1 Adam Tkac 2009-03-11 10:51:39 EDT
I think this thread talks about this issue:
https://www.redhat.com/archives/fedora-devel-list/2009-March/msg00746.html
Comment 2 James Laska 2009-03-11 11:00:06 EDT
Indeed, this appears to be the same issue.

sh-4.0# dmesg  | tail
SQUASHFS error: zlib_inflate tried to decompress too much data, expected 131072 bytes.  Zlib data probably corrupt
SQUASHFS error: squashfs_read_data failed to read block 0x6c3cfd
SQUASHFS error: Unable to read data cache entry [6c3cfd]
SQUASHFS error: Unable to read page, block 6c3cfd, size cf05
Comment 3 James Laska 2009-03-11 12:07:46 EDT
After talking to jkeating, reassigning this known issue to kernel and setting title appropriately
Comment 4 Chris Lumens 2009-03-11 13:13:22 EDT
*** Bug 489520 has been marked as a duplicate of this bug. ***
Comment 5 Sebastian Vahl 2009-03-11 13:18:54 EDT
I've got the same error when booting a live image created with kernel-2.6.29-0.218.rc7.git2.fc11. Only the block and the cache entries differs.
Comment 6 Kyle McMartin 2009-03-11 16:39:29 EDT
Should be fixed in 0.235.rc7.git4.fc11.

regards, Kyle
Comment 7 Sebastian Vahl 2009-03-12 06:36:15 EDT
Confirmed to work on live images with 0.237.rc7.git4.fc11
Comment 8 Remy Maucherat 2009-03-12 10:38:01 EDT
Confirmed as well.

Note You need to log in before you can comment on or make changes to this bug.