Bug 489720 - RPM fails to install files
RPM fails to install files
Status: CLOSED DUPLICATE of bug 489235
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i586 Linux
low Severity urgent
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2009-03-11 11:19 EDT by Scott Douglass
Modified: 2009-03-12 10:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 10:27:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Douglass 2009-03-11 11:19:16 EDT
Description of problem:

On the OLPC XO platform, install of .rpm package appears to work normally, however no files are actually installed. The rpm db is updated however. It possible, for example, to rpm -e the package even though the package was not really installed.

Version-Release number of selected component (if applicable):

rpm-4.7.0-0.beta1.2.fc11.i586

How reproducible:

100%

Steps to Reproduce:
1. yum install ghex2 (rpm install appears normal)
2. which ghex2 (no such file...)
3. rpm -e ghex2 (works)
  
Actual results:
No files are installed.

Expected results:
Files from the rpm package should be installed

Additional info:

rpm-4.6.0 works fine
Comment 1 Panu Matilainen 2009-03-11 12:05:24 EDT
Most likely dupe of bug 489235. Upgrading to rpm-4.7.0-0.beta1.3.fc11 should fix but note that you'll need to do the upgrade with %_install_langs set to "all" (or commented out) to avoid losing rpm itself...
Comment 2 Panu Matilainen 2009-03-12 10:27:40 EDT
With no further info, considering this as a dupe (and fixed). Feel free to reopen if you still see it with rpm-4.7.0-0.beta1.3.fc11.

*** This bug has been marked as a duplicate of bug 489235 ***

Note You need to log in before you can comment on or make changes to this bug.