Bug 489721 - RFE: missing a README.FEDORA and README.EPEL
RFE: missing a README.FEDORA and README.EPEL
Status: CLOSED DUPLICATE of bug 475841
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 11:24 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 09:03:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-03-11 11:24:01 EDT
Description of problem:

Having a README.FEDORA and README.EPEL (or INSTALL.FEDORA) is an important piece of missing information with this package.

Version-Release number of selected component (if applicable):

mediawiki-1.14.0-45.fc10.x86_64

Steps to Reproduce:
1. yum install mediawiki
2. rpm -qd mediawiki
  
Actual results:

The README indicates that the INSTALL file should be referenced for installation instructions.  

Expected results:

There is no INSTALL file.

Additional info:

 * A recent post on epel-devel-list also notes that if we just add an INSTALL.FEDORA (or similar) file it might help clear things up - https://www.redhat.com/archives/epel-devel-list/2009-March/msg00017.html
Comment 1 Austin 2009-03-26 03:40:30 EDT
For some reason, it's not listed by that rpm query - it's found in here: /usr/share/mediawiki
Comment 2 Axel Thimm 2009-03-29 12:54:17 EDT
(In reply to comment #0)
> Steps to Reproduce:
> 1. yum install mediawiki
> 2. rpm -qd mediawiki

Have you tried rpm -qi?
Comment 3 Austin 2009-03-30 03:22:53 EDT
It still doesn't solve the problem that the README file says to read the INSTALL file... which isn't listed by the RPM.
Comment 4 James Laska 2009-03-30 12:24:59 EDT
# rpm -q mediawiki
mediawiki-1.14.0-45.fc10.x86_64

# rpm -ql mediawiki | grep README
/usr/share/doc/mediawiki-1.14.0/README

This is the upstream README file.  What is needed is a distro specific README in addition to the upstream README file that outlined a few setup steps.

I would recommend a README.FEDORA that lists a similar setup procedure to that noted in https://www.redhat.com/archives/epel-devel-list/2009-March/msg00020.html.
Comment 5 Ricky Zhou 2009-07-23 09:03:43 EDT
Hi, thanks for the bug report, it looks like you aren't alone in wanting a better documented install process.  Bugs for the issues you bring up have been filed at bug 475841 and bug 459532 and unfortunately, have had no maintainer response in 7 months and 11 months, respectively.  In bug 475841, the reporter even wrote a draft of what a README.FEDORA would look like.

Hopefully we can polish up the file posted in the first bug and then see if we can get any maintainer attention on this issue.

*** This bug has been marked as a duplicate of bug 475841 ***

Note You need to log in before you can comment on or make changes to this bug.