Bug 489724 - pulsaudio and ekiga don't like each other
pulsaudio and ekiga don't like each other
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 11:24 EDT by Nathaniel McCallum
Modified: 2018-04-11 09:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-23 15:16:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ekiga log (36.19 KB, text/plain)
2009-03-11 11:25 EDT, Nathaniel McCallum
no flags Details
Log from pulse audio during an ekiga session which exhibits the symptoms (1.33 MB, text/plain)
2009-03-31 14:10 EDT, Nathaniel McCallum
no flags Details
pulse.log (355.23 KB, text/plain)
2009-05-15 09:42 EDT, Martin Jürgens
no flags Details

  None (edit)
Description Nathaniel McCallum 2009-03-11 11:24:43 EDT
When using ekiga with pulseaudio, the audio is garbled and there is tons of spew in the log.  Turning off (or bypassing) pulseaudio makes ekiga work again.  I'm not sure who's fault it is, but I've attached a log from ekiga.
Comment 1 Nathaniel McCallum 2009-03-11 11:25:31 EDT
Created attachment 334820 [details]
ekiga log
Comment 2 Lennart Poettering 2009-03-31 12:45:07 EDT
Which output did you select in ekiga?
Comment 3 Lennart Poettering 2009-03-31 12:45:34 EDT
Also, what kind of 'spew' is in the logs?
Comment 4 Nathaniel McCallum 2009-03-31 12:49:11 EDT
I kept all defaults (i.e. "Default").  This should work out of the box, no?

The logs are attached, look for yourself.
Comment 5 Lennart Poettering 2009-03-31 13:00:09 EDT
Logs? I only see ekiga logs...
Comment 6 Lennart Poettering 2009-03-31 13:16:08 EDT
Hmm, those ekiga logs are not helpful at all. Comparing them with the actual code shows that those messages actually hide the actual cause of the problem.

http://www.opalvoip.org/websvn/filedetails.php?repname=Opal&path=%2Fptlib%2Ftrunk%2Fplugins%2Fsound_alsa%2Fsound_alsa.cxx

Most likely these are just underruns.The PA log output (with -vvvv) could prove that.
Comment 7 Nathaniel McCallum 2009-03-31 14:09:50 EDT
Sorry, pulseaudio logs attached (pulseaudio -vvvv 2>pulse.log).
Comment 8 Nathaniel McCallum 2009-03-31 14:10:52 EDT
Created attachment 337369 [details]
Log from pulse audio during an ekiga session which exhibits the symptoms
Comment 9 Nathaniel McCallum 2009-04-14 10:20:21 EDT
Any update?
Comment 10 Lennart Poettering 2009-04-23 18:24:41 EDT
Hmm, it seems as if Ekiga misbheaves and underruns all the time and even reconnects. No clue. If I'd knew how to reproduce this I'd have a closer look.
Comment 11 Nathaniel McCallum 2009-04-23 18:39:50 EDT
1. Install ekiga
2. Sign up for an ekiga.net account
3. Make a call to 500@ekiga.net (the ekiga echo test)
Comment 12 Lennart Poettering 2009-04-23 19:09:23 EDT
That behaves correctly here, that's the problem.
Comment 13 Martin Jürgens 2009-05-15 09:41:03 EDT
same problem. to reproduce: 

a ) start ekiga
b ) call 200@hd-telefonie.avm.de

I'm using the hda_intel driver. I noticed such output in dmesg:

ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32

It seems to depend on if an other application is accessing Pulseaudio. Because when Ekiga runs only, it works fine. When I have Rhythmbox running, play music, then start Ekiga and run the test, I have that bug. Would be nice if you could look into it. I'll also attach my pulse.log
Comment 14 Martin Jürgens 2009-05-15 09:42:17 EDT
Created attachment 344150 [details]
pulse.log
Comment 15 Nathaniel McCallum 2009-05-15 10:03:44 EDT
I too am using hda_intel... perhaps this is a driver bug?
Comment 16 Bug Zapper 2009-06-09 08:08:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Martin Jürgens 2009-06-09 18:04:30 EDT
whats up there? this bugs renders ekiga, a application that is shipped by default, completly unusable in a stable fedora release. i am a little bit disappointed.
Comment 18 Richard Schwarting 2009-08-05 00:35:29 EDT
Eugen Dedu mentions a couple things that might rectify this in the upstream bug[1]: A recent fix in opalvoip and the adventure of a pulse ptlib audio plugin.  Due to a recent audio issue with Fedora[2], my audio sounds like hell and dies very quickly, so I'm not sure if my negative experiences with opal/ptlib/ekiga from HEAD are still related to this, or my new issue.  

1. http://bugzilla.gnome.org/show_bug.cgi?id=586034
2. https://bugzilla.redhat.com/show_bug.cgi?id=506075
Comment 19 Matěj Cepl 2009-08-05 02:08:33 EDT
Actually, according to http://bugzilla.gnome.org/show_bug.cgi?id=586034#c3 it might be worthy to upgrade opal (again), apparently it grew pulse audio plugin in meanwhile.
Comment 20 Eugen Dedu 2009-08-05 03:42:03 EDT
Hi,

"worthy to upgrade opal": Upgrading to opal/ekiga from unstable is not a good idea, as there are still a few important bugs to fix.  Instead, you could add the ptlib pulse plugin as a patch (note: I have not compiled it against the stable version).

As for the the audio fix, you could also wait a few days (max one week), until 3.2.6 appears, it's as you wish.
Comment 21 Peter Robinson 2009-08-05 04:25:49 EDT
(In reply to comment #19)
> Actually, according to http://bugzilla.gnome.org/show_bug.cgi?id=586034#c3 it
> might be worthy to upgrade opal (again), apparently it grew pulse audio plugin
> in meanwhile.  

It has the support in the trunk. there is no stable release. It will go into rawhide when there is an ekiga 3.3 devel release but that will unlikely be for F-12. I had a look at just pulling in the pulseaudio support but it didn't work well (generally just locked up ekiga entirely)
Comment 22 Matěj Cepl 2009-08-05 04:29:57 EDT
(In reply to comment #20)
> "worthy to upgrade opal": Upgrading to opal/ekiga from unstable is not a good
> idea, as there are still a few important bugs to fix.  Instead, you could add
> the ptlib pulse plugin as a patch (note: I have not compiled it against the
> stable version).

Thanks for jumping here, even though my silly comments on b.g.o.
Comment 23 Eugen Dedu 2009-08-15 12:08:43 EDT
From http://mail.gnome.org/archives/ekiga-list/2009-August/msg00054.html:

> > 2) I have pulseaudio running on my system and I have to use the
> > "Default" (PTLIB/ALSA) sink therefore, but my card (and webcam) are
> > constantly bombarded. If I have pavucontrol open and test any sound from
> > Ekiga, the cpu goes to 99% activity and I have to kill he stream.
> > 
> 
> Does it work better without pulse audio? If so, please report a bug to
> pulse audio.

Indeed if I kill the server or run with pasuspender and access the
soundcard directly then I don't see any difference in the audio quality
but I don't get the problems mentioned above. These issues are the usual
ones with Skype as well.
Comment 24 Adam Williamson 2009-10-20 14:36:23 EDT
Do we have a clear handle yet on the exact intersection of PA / Ekiga / kernel driver for this issue? FWIW, I use Ekiga 3.2.6 with Opal 3.6.6 in current F12, via a USB headset (so snd-usb-audio), and have not had any problem.

Lennart, is there sufficient information yet to pin down what's the source of trouble here? What other information might you need?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Matěj Cepl 2009-10-23 12:57:15 EDT
Actually, this might be really fixed. I have done extensive testing various SIP/Jingle clients (including ekiga) in the last month, and I haven't met any problems with Pulseaudio running.

Let's close it for now.
Comment 26 Lennart Poettering 2009-10-23 15:16:32 EDT
Okeydokey. Closing.
Comment 27 Adam Williamson 2009-10-26 16:57:12 EDT
matej: were you testing on F11 or F12?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 Nathaniel McCallum 2009-10-26 17:21:42 EDT
I can confirm, works well for me on F12.
Comment 29 Adam Williamson 2009-10-26 21:35:37 EDT
nathaniel: that's not a 'confirmation', this bug is for F11. it's possible for it to be OK on f12 but not on f11, since Ekiga in f12 is apparently using PulseAudio directly, while Ekiga on f11 is not.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 30 Peter Robinson 2009-10-27 03:16:18 EDT
(In reply to comment #29)
> nathaniel: that's not a 'confirmation', this bug is for F11. it's possible for
> it to be OK on f12 but not on f11, since Ekiga in f12 is apparently using
> PulseAudio directly, while Ekiga on f11 is not.

Ekiga in F-12 is using exactly the same methods and version for the audio as F-11. There's no difference in the packages. Real PulseAudio support in ekiga is not due until 3.4.x. If audio works better in F-12 rather than F-11 that is due to improvements in PulseAudio as the ekiga versions are for all intents and purposes identical.
Comment 31 Matěj Cepl 2009-10-27 07:17:33 EDT
(In reply to comment #27)
> matej: were you testing on F11 or F12?

F12, but I think comment 30 is right ... it is irrelevant as far as Ekiga itself goes (of course, Pulseaudio in F11 is probably quite different than what F12 has). OTOH, this was closed with NEXTRELEASE, which may be an honest assesment of the situation. I don't know.
Comment 32 Adam Williamson 2009-10-27 21:40:08 EDT
Ah, I see, thanks Peter - I misunderstood from earlier discussion that F12's Ekiga used a newer opal which did direct PA support, but F11's didn't. Thanks for the correction.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.