Bug 489732 - Segmentation fault in opreport - oprofile unusable in F11
Segmentation fault in opreport - oprofile unusable in F11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: oprofile (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: William Cohen
Fedora Extras Quality Assurance
:
Depends On: 467651
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 11:47 EDT by Jochen Roth
Modified: 2009-04-09 11:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 11:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Roth 2009-03-11 11:47:37 EDT
With the current rawhide version of oprofile, binutils and glibc opreport segfaults when using the -l option (see below)

I saw in koji that the rebuild of oprofile for F11 failed.

The most current working version oprofile-0.9.4-3.fc10 has the same problem as described in bug #467651
Recompiling from source (as suggested in comment #7) didn't help a lot as opreport is segfaulting now (see below)

binutils-2.19.51.0.2-16.fc11.i586
binutils-devel-2.19.51.0.2-16.fc11.i586
glibc-2.9.90-8.1.i686
glibc-devel-2.9.90-8.1.i586


gdb --args opreport -l --merge tgid
...
...
Counted CPU_CLK_UNHALTED events (Unhalted clock cycles) with a unit mask of 0x00 (Unhalted core cycles) count 100000
Samples on CPU 0
Samples on CPU 1

Program received signal SIGSEGV, Segmentation fault.
interesting_symbol (sym=0x0) at bfd_support.cpp:336
336		if (!sym->section) {
Missing separate debuginfos, use: debuginfo-install libgcc-4.4.0-0.23.i586 libstdc++-4.4.0-0.23.i586
(gdb) bt
#0  interesting_symbol (sym=0x0) at bfd_support.cpp:336
#1  0x080abd01 in op_bfd::get_symbols (this=0xbffff234, symbols=@0xbffff194) at op_bfd.cpp:217
#2  0x080acb03 in op_bfd (this=0xbffff234, fname=@0x81ac0d8, symbol_filter=@0x8198384, extra_images=@0xbffff4cc, ok=@0xbffff31f) at op_bfd.cpp:171
#3  0x08084b9d in populate_for_image (samples=@0xbffff4a8, ip=@0x81ac0d8, symbol_filter=@0x8198384, has_debug_info=0x0) at populate.cpp:70
#4  0x080544e9 in opreport (spec=@0xbffff634) at opreport.cpp:576
#5  0x0805b7c1 in run_pp_tool (argc=4, argv=0xbffff734, fct=0x8053d50 <opreport>) at common_option.cpp:210
#6  0x0804cabd in main (argc=4, argv=0xbffff734) at opreport.cpp:590
Comment 1 Jochen Roth 2009-03-13 08:34:55 EDT
I'm not able to reproduce this problem anymore. All I did was upgrading to the latest available kernel in rawhide.
Comment 2 William Cohen 2009-04-09 10:33:54 EDT
Just rebuilt oprofile for F11, oprofile-0.9.4-6.fc11 (http://koji.fedoraproject.org/koji/buildinfo?buildID=97181). Could you check that this problem no longer occurs with the newer oprofile?
Comment 3 Jochen Roth 2009-04-09 11:14:08 EDT
Yes, I just installed the latest build from koji on F10 and everything works now as expected! 

Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.