Bug 489733 - gdm crashes on language selection
gdm crashes on language selection
Status: CLOSED DUPLICATE of bug 487593
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 11:49 EDT by Harald Hoyer
Modified: 2009-03-11 14:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 14:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm log file with debuginfo traceback (29.25 KB, text/plain)
2009-03-11 11:49 EDT, Harald Hoyer
no flags Details

  None (edit)
Description Harald Hoyer 2009-03-11 11:49:00 EDT
Created attachment 334825 [details]
gdm log file with debuginfo traceback

Description of problem:
click user, try to select language, scroll in language window.. boom


Version-Release number of selected component (if applicable):
gdm-2.25.2-14.fc11.i586

How reproducible:
every time
Comment 1 Matthias Clasen 2009-03-11 14:09:07 EDT
Crash is inside pango:

Program received signal SIGTRAP, Trace/breakpoint trap.
0x0000003124c421e7 in g_logv () from /lib64/libglib-2.0.so.0
(gdb) bt
#0  0x0000003124c421e7 in g_logv () from /lib64/libglib-2.0.so.0
#1  0x0000003124c42583 in g_log () from /lib64/libglib-2.0.so.0
#2  0x0000003ce480b1e3 in pango_fc_fontset_finalize (object=0x25fdf20)
    at pangofc-fontmap.c:842
#3  0x000000312500d9ef in g_object_unref () from /lib64/libgobject-2.0.so.0
#4  0x0000003124c29eaa in ?? () from /lib64/libglib-2.0.so.0
#5  0x0000003124c2b40a in ?? () from /lib64/libglib-2.0.so.0
#6  0x0000003ce480b9e5 in pango_fc_fontset_cache (
    fcfontmap=<value optimized out>, fontset=<value optimized out>)
    at pangofc-fontmap.c:1619
#7  pango_fc_font_map_load_fontset (fcfontmap=<value optimized out>, 
    fontset=<value optimized out>) at pangofc-fontmap.c:1656
#8  0x0000000005eb7761 in ?? ()
   from /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so
#9  0x0000003127c191b3 in itemize_state_update_for_new_run (
    state=<value optimized out>) at pango-context.c:1288
Comment 2 Matthias Clasen 2009-03-11 14:12:59 EDT

*** This bug has been marked as a duplicate of bug 487593 ***

Note You need to log in before you can comment on or make changes to this bug.